The honeymoon is over, time to settle down with my 8TB cloud pair

It has been an arduous week mainly due to the 30 plus hours of file copying and 3 days of file compares to ensure that the data arrived safe and it did, and another 30 hours was spent on duplicating the copied files to the second Cloud that is now assigned the task of being the mirror.

As you can see, my bookshelf has cleaned up nicely reducing the clutter of
1x8port switch
6xpower adapters mounted on a power bar on the wall

down to

2xpoweradapters on the floor.

With book covers, the bookshelf is once again a covert data center.

Seriously I have mixed feelings about the BusyBox OS as WD has completely removed all possibility of hacking the not-quite-linux in a closed garden box. I do not know if you can even downgrade to the last version as any modification to the files are lost upon reboot as it rebuilds a fresh new copy of its OS into Ramdrive.

Logs are almost non-existent as sleep info is no longer logged, thus removing the OCD need to ensure that the drive sleeps through the night. It wakes at 8AM for atop that rotates your log files and deletes older logs. Throughout the day it will wake for various services of which you have no control over,since you cannot kill the cron but since you don’t have any control you begin to realize that you really don’t care anymore and you let it run as it was designed to run. However, with the Cloud Access set to OFF, the scans do seem to be turned off and the drive does sleep for hours on end but not days.

You can also SSH to the drive and “stop” the scans since the programmers left exactly the 4 file controls you need to turn them off (I have no idea why but the files are just sitting there), but the scans automatically turn themselves back on when you remote access the drive thus making the control files totally moot. In fact if you had the scans off and had 3 attached USB drives, the system will power up the scans and lock your system when you attempt to use remote access.

The only way to ensure that remote access will work is that you need to let the scans run from the start up of the Cloud. Even with the attached USB drives (tested up to 3 attached drives) and the scans running in the background (you can tell by the incessant hard drive chatter), remote access to all drives including the attached USB drives are lightning fast.

I gave up trying fix the Cloud and instead use the cloud for what it is - a cloud drive. It is fast with up to 120MB/s reads and 100MB/s writes on the local network, access of the attached USB drives are about 80MB/s writes and 100MB/s reads which is amazing since even a direct read/write USB3 drive is around the same speed; thus you almost get USB3 speeds through a network cable.

The most fascinating part to the new cloud is the ability to use a un-powered USB3 hub to connect 3xUSB3 MyBooks to the cloud making the NAS as versatile as its QNap brethren. I probably could connect more, but I only had 3 drives to test with.

Small minor changes includes making Public Shares private, sending links to files do work now although it may have worked with gen1 but I had never tested it again until now. Turning on Cloud access will turn on the scans and it is still a notoriously agonizingly resource hogging program where everything on the NAS slows down to a crawl, but the saving grace is that the gen2 device is a little bit faster and the programmers have programmed the scans to recognize that the user takes priority, thus starting up a movie automatically reduces the priority on the scans and on many occasions the scans stops immediately until it notices a lull in your activities before the annoying clicking resumes.

Understandably that once upon a time we bought the Clouds as a linux in a box with an attached hard drive NAS as a bonus. We fell in love the quirky linux in a box Cloud that we managed to patch and was waiting for WD tp release a full patched system with OS3 but instead we got this new and improved Cloud that doesn’t resemble anything that we knew of.

Today it is a full fledge turn-key Cloud-NAS box that actually works as is. The scans no longer crashes the system nor do they hinder access to multiple attached USB drives. It really seems that the Cloud has finally grown up to be the Cloud that we had always wanted. Do we want it though?

The honeymoon is over and the new cloud is sitting in the same place where the old clouds use to sit. I mostly ignore whether or not the Cloud is asleep as it does sleep but I know not how deeply nor how long. Both drives have been set to Cloud Access OFF so that it doesn’t scan my files.

I’ll probably turn on Cloud Access to the Main Cloud soon to allow remote access so I can watch movies in the gym.

The new and improved My Cloud is a breath of fresh air and I no longer SSH into the drive to set the drive to no-sleep, nor do I check how soundly the drive slept last night and finally the most important is that after this, I won’t have anything to complain about since the new Clouds seems to be working smoothly and silently; for now.

Congrats to WD on a very successful product.

p.s. Please WD, add the feature of allowing us to turn the scans off even with Cloud Access. Thank you.

My honeymoon is over also. The gen2 device causes my video streaming to freeze when the network cable is connected. System ran fine during the day. But when I started to stream video
from my DNS-323 NAS or Netflix. It would start up play for a few seconds then stop. When I disconnected the cable the led turned red. Put the cable back and the led turned blue. Nice of them to switch the led colors. They definitely don’t use the colors in the script on the Gen2. I did find out that the Gen2 is different than the busybox on my DNS-323. They seem to use a program called xmldbc to generate xml files to configure the device.
I don’t have the time to try to learn this device. Since I can’t work with the device at night. I don’t have time during the day. To big of a honeydew list.
I was able to copy the busybox executable to the Gen1 device. Did a busybox --help which displayed the help data. But when I copied a gen1 file to the gen2 it would not work. I also tried to copy a standard debian file to the gen2 and it also didn’t work.
I think the best thing for me is to return it to Best Buy tomorrow.


I am alone then with my new gen2 :sob:


Just spent the last few hours prepping all my clouds and my books to be sold on craigslist. Updated all my Clouds to the latest firmware, then did a quick restore which was really painless as it took only ten minutes or so, in comparison to the Full Restore which would have taken days but ensures that all data is wiped and unrecoverable.

Since my data is not sensitive in nature a quick restore is good enough. Rebooted to check that the Clouds appeared empty and packed them up for sale.

The WD My Books were a bit more difficult as deleting 750,000 entries took hours as each entry had to be deleted one by one by the system. Yup should have just formatted it in windows.

So that is that… hopefully my old clouds and my books that served me for the last year and the original that served me for almost 3 years, goes to a good home; a home that gives me my asking price :stuck_out_tongue:

It took nine days to sell off my collection of my clouds and my books. It was very hard to sell as it seems that nobody these days have money or at least no money to spend on tech like clouds. However, since I’ve had good experience on selling on craigslist, I started to polish the craigslist ad to include words like “Isn’t it time to backup your Mac or PC, then this is the device that will do it for you!”, of which the last two sold tonight.

One of the other minor changes I had to make was “NOT” to try to sell all 6 devices at the same time as it would seem to them that I’m just dumping a bunch of used leftover devices from an upgrade which is what it was, but somehow the clouds were devalued by selling them as a cluster of used hard drives. So I started to sell everything one by one and thankfully the last two were sold to two different individuals tonight.

The cost of buying 3 clouds and 3 my books came to a total of $1040 and I sold them all for $830, which came to a total loss of $210; which is pretty good I would say.

So it is official that I am no longer the owner of any cute linux driven cloud but an owner of a busybox, non user programmable or modifiable cloud now.

It would seem that I won’t have any usable content to share in this forum any longer unless my clouds break down of which I would once again complain loudly in a form of a rant, but since the new clouds are not modifiable in any way, I have nothing more to add to this forum except

good bye.

1 Like

Thanks for your time here Ralphael … you have contributed to this community for a long time and I wish you all the best with your 2 new My Clouds.