"The handle is invalid" error

WD My Cloud 3TB.

Two users setup on disk with different access settings. Both accounts are password protected.

Problem is when I try to access some subfolders within a share, I get this mesage:

img1 cloud handle error.jpg

I have full user access to this share.

Windows 8.1 64b

Similar problem occurs on girlfriend’s laptop (w7, 64b) - she has some shares setup as read only, and I think she gets this message on the same folders:


this share is setup as read-only for her.

Thanks for help and ideas!

(edited - more pictures added and deleted irrelevant parts of post)

ok. I managed to login to WD My Cloud, using PREVIOUS password (password 1)

however, to login to mycloud in web browser, I used my new password (password 2)

later, none of the passwords is working.

trying to browse the disk using windows explores, no luck - password denied, even on root user. deleted credentials - all worked for a while, then the same problem.

Does somebody know what’s going on?

I find software and firmware very disappointing - the cloud has a potential to be a great product, but it should not have been released…yet.

cloud password.jpg


I changed Public access of ALL shares to ON.

Then I deleted network credentials and connections, so it’s all working fine, but that’s not the way I want it - I want to use shares and proper user rights.

I also got into the folder, previously denied (The handle is invalid error).

Same problem here…

Not sure if anybody still checkes this thread, but I had a similar problem and seem to have found a solution.

**warning**: my solution uses SSH, and I recommend you only do it if you have at least some linux knowledge.

My problem occurred when I tried to copy files from a USB drive I plugged in to the My Cloud to a share on it. I thought this would be esay and faster than transferring over the network, but it proved more difficult. I ended up using the linux terminal via SSH to copy the files over, but the problem is then that I was not the owner of them, but root was. Below is my solution in steps.

  1. Enable SSH - Within the web interface for the My Cloud, go to Settings > Network and enable SSH.

  2. Log in using a program such as PuTTY, username is root password is welc0me by default.

  3. Navigate to your share folder with “cd /shares/” where is the name of your share. If it is only one subfolder you can’t access, add its path to the end of the command (e.g. “cd /shares//folder”).

  4. To see who the owner is, first install a program called less “apt-get install less”. Then, type “tree -pufid | less” to see the details (owner is second column).

  5. In the directory above the folder you can’t access (i.e. if it is a share, go to the /share/ folder using cd), type "chown -R . This should set your user to the owner, and give you access to the folders from windows explorer again.

Sorry if this doesn’t fix the problem for anybody or if it is a little too advanced, feel free to ask me to clarify if needed.