The h: drive in inaccessible, the parameter is incorrect

#1

Hi,

I have a problem with a recently, yesterday the 23rd, external WD Elements SE 4tb hdd.

When i plug it into my front usb 3.0 ports, it keeps randomly disconnecting and reconnecting. the first time i plugged it in in gave me a error message, “the h: drive in inaccessible, the parameter is incorrect”. It hasn’t displayed that message again, but every time i plug the drive into either front usb 3.0 port (theres 2) it repeatedly connects and disconnects.

So far, i have tested the hdd on two other PC’s in my house and it detects and works fine. I ran a SMART test and it passed. i also tried different USB thumb drives / hdds /mice on the both front usb 3.0 ports and theyre ok too.

everything works fine in every configuration except this new WD elements se 4tb drive in the front 2 USB3.0 ports. The back of the pc works, as does the monitor hub

Im running Win 10 64bit, latest updates, asrock z87 extreme motherboard.

#2

Maybe your two front USB ports have issue, might not give enough power to the external drive. As you mention the ports on the back of the computer work fine. Check you BIOS setting if you can increase the power for the two front USB ports.

#3

hi, thanks for the reply.
I just thought/found something. Originally when i plugged the drive in to my windows 10 pc, it said “h:/drive is inaccessible:, the parameter is incorrect”.
this didnt mean a lot to me, h drive wasnt being used.

that was what i thought, until i logged into my windows 7 os (dual boot pc with windows 10) and i found daemon tools (virtual disc mounting) using the h drive as its default virtual drive.

does that give anyone any ideas?

#4

If H: has been use, then you can check in the Disk Management if you drive has already been partition and giving a drive letter.
What this Youtube video https://www.youtube.com/watch?v=_HgjasKuOBw

#5

Hi,

There can be many possible reasons for drive connecting and disconnecting issue such as bad sectors, overheating, file system corruption of drive, etc. I have a reference link for you where same topic has been discussed by the author. You can visit this blog https://www.stellarinfo.com/blog/why-your-usb-flash-drive-is-constantly-disconnecting-reconnecting/ to get the best answer for your problem.

#6

thanks ill check it out.

i just transferred all the information off it,(took 9 hrs) then deleted the partition and recreated a partition.

still the same problem just continuously disconnecting from the front 2 usb3.0 ports, but no other ports. im gonna check bios next

#7

ok i tried in bios to disable legacy usb settings, that didnt help either. the only thing that works with this drive is when i use the rear ports or the usb 3.0 hub attached to my monitor. WHY?! its driving me crazy :frowning: . the usb.3.0 hub is slower and the rear ports hard to access. EVERY other usb3.0 4tb harddrive i have works fine on this pc. and the wd elements se 4tb harddrive works fine on the other PC plugged into the front usb3.0 ports, (the other pc has the exact same motherboard as my pc, its my spare media pc).

#8

If it works on your other PC then for sure there is something wrong with this PC. You could buy a USB extension cable to use the port in the rear.

#9

yes i agree there’s something wrong with my pc :frowning: without knowing exactly what or how to fix it, ive ordered a longer usb cable. that will have to suffice.

#10

The front USBs port normally is part of another board then connect to a wire to your motherboard. That board might be bad, but it is better to use the extension USB cable and use the USB ports in the rear.

#11

yes, i finally agree. it might be a windows issue, but ill leave it with a longer cable to the rear ports for the time being.