The External Drive's Icon Does Not Appear In My Computer

Hello, Until recently My Book Essential used to work on my Vista operated laptop, but not anymore. The icon disappeared. But on my XP operated desktop it never worked. The icon never appeared. The icon is also missing from Disk Management and Device Manager. So, at first it worked only on one of my computers, but now it does not work on either of them. This just shows me that the problem is neither with the external drive nor with the computers. The problem could be elsewhere, in some section of the computer something like registry, installation, USB or other compatibility, connectivity, data transfer or some software problem; maybe some dll’s, files, or something is missing. I don’t know much about computers, but it looks to me that either the external drive does not send a signal to the computer or the computer does not recognize the signal. The external driver gets enough power, the data cable is new, the drive spins up so it seems to function well without suspicious noise. The power adapter is plugged directly into the wall. I tried other USB ports, yet no change. The cable that I am connecting My Book to the computer is a USB Standard Type A plug on one end and Micro-B USB 3.0 compatible on the other end. How about changing Micro-B USB 3.0 to Micro-B USB 2.0? Speculation: Before I got WD I used registry cleaners (AVG PC TUneUp, CCLeaner) on the desktop without any problems. On this computer WD never worked. On the laptop I never used registry cleaners and WD worked on it. When I started using registry cleaner on the laptop WD stopped showing the icon in My Computer. Now, I don’t know if the registry cleaner was a direct cause of this problem or not. I did not discover the problem until much later. I restored the old registry, but there has been no change. Any consideration is appreciated and helpful response is welcome!

Check if the drive appears on disk management

try a different USB cable

Hi, The drive does not appear in Disk Management. The cable is new. The cable I am using is a USB Standard Type A plug on one end and Micro USB 2.0 compatible, Micro-B USB 3.0 on the other end. In my original message I made a mistake, because I said that it is Micro USB 3.0 compatible. Thanks for your reply.

What happens when you update this devices drivers on device manager?

I cannot find the drivers for this device. In Device Manager under Disk drives I only have Generic Flash HS-CF USB Device, Generic Flash HS-COMBO USB Device and the WDC hardrive WDC3200AAJB-00TYA0. So, any icon, driver, name that would indicate that I have an external drive is missing. The external drive is not recognized by my PC.

For me it was a problem of the univeral serial bus controller not working correctly (not sure why, it was either corrupted, beat on as a child or was just having a bad hair day. Whatever)

I went to device manager (Windows 7) --> Control Panel --> Device Manager --> Universal Serial Bus Controllers -->

In my pc I have a "Renesas Electronics USB 3.0 Host Controller (I have two actually). One of them had the yellow exclamation icon on it.

I right clicked on the one with the yellow exclamation icon, selected Properties then selected the Driver tab.

The computer said the driver was functioning properly, but I said “liar” and tried updating the driver. That didn’t seem to change anything so disabled the driver. Then I enabled it again, and voila, the computer recognized my external hard drive and all was good in my world again. Not exactly sure why this worked but sometimes even the dumb get lucky.

Posting this with the hopes that it helps someone else out. Best of luck.