The disk inserted was not readable by the computer

Hi, I have a 2TB WD MyPassport Ultra which was used to back up of my MacBook Pro and store holiday video and still images . When I plunged it in my MBP yesterday, there was a message “the disk inserted was not readable by the computer” I ejected the disk and tried another MacBook and the same message appeared. Disk utility can detect the HDD but cannot repair. Help!

Can you do some troubleshoot for me. Open Terminal and type in “diskutil list” for your external hard drive do you see “Apple_HFS” or what other format do you see. Maybe you can attach a screenshoot for us. What version of OSX are you using? Did you use TimeMachine Backup?

This message is usually an indication of loss of hard disk drive spaces. When mounted, just check the size shown in the Disk Utility. It might be possible that it have some MB or few KBs of sizes. You can download Mac data recovery tool to check if the software can identify the FILESYSTEM and DRIVE SIZES correctly. If your HD file structure is damaged, then it will be difficult to recover and format the hard drive. https://www.stellarinfo.com/data-recovery-mac.php

Hi Jebusx, thanks for reply.

Screenshot as follows

OSX Yosemite version 10.10.5.

Yes, there is TimeMachine backup in this problematic disk.

Hi DonaldKepler, I have tried EaseUS free trial and it could identify all the files but when I pressed “recover”, EaseUS asks me to buy and I gave up.

It seems like your device got initialize under MSDOS instead of OSX GUID. This almostly been done under Linux system. Yup, the best way to recover is to try the methos from DonaldKepler. OSX diskutil can’t repair device, if it is not HFS format file system.

Hi, do you think Disk Warrior can help? It is expensive but I guess I may need this to deal with future mishap.

Most data recovery free/pay will give you the same result. They all just give you a bunch of files that can recover.

Same problem. I have a RAID Thunderbolt Duo, (2) 3 TB discs.