"The application has encountered an unexpected error and is now exiting"


#1

A couple weeks ago I was uploading pictures to the internet from my external and suddenly all of the picture folders appeared empty. I looked through the rest of the drive and all of the folders were empty. I checked and it said that the drive still had the same amount of data, so data hadn’t been lost. I restarted the computer and when I tried to connect the drive I got a “The application has encountered an unexpected error and is now exiting” message. I un-installed and re-installed the WD Smatware and updated the firmware…no luck. The drive works on other PC’s and Macs running Windows, none of the data is corrupted and it opens fine.  I can still open the WD Smartware program and view details about my own computer. When I connect the external it doesn’t close the program, but I receive the above error…The program remains open showing my computer I just cannot view the drive. In the my computer the VCD shows up in the E: drive, but nothing in the F: drive. I look in the device manager and the drive shows up as “not enabled” and cannot be enabled. It does not show up in the disc manager, but the VCD again shows up in the E: drive. I have connected other external USB devices and have had no problems. I have tried pretty much everything the WD people said to do (the MSCONFIG stuff, checked the drive for errors on other computer, update drivers,  tried different USB ports, un-install/re-install WDSmartware, update BIOS, TweakUI etc. ) and I am still having no luck…

I am using Windows XP and I own the Passport Essential (SmartWare) 500 Gig, WDBAAA5000ABK model #.


The application has encountered an unexpected error and is now exiting
#2

Since the drive works on other computers there is obviously an error in your operating system as far as installation of the drive.

Go to Device Manager (with your USB drive connected) and expand the row (should be at the bottom of the list)  that says “Universal Serial Bus Controllers”.  Right click on “USB Mass Storage Device” and then “uninstall”. Reboot your computer - the OS should install the device again on reboot.


#3

PS - I would suggest disconnecting all your other USB devices before uninstalling the WD portable drive (and also doing so if you decided to upgrade the firmware).


#4

You rock! That worked perfectly. Thanks a lot!!!