TFTP method

I’ve been searching the community for information about the tftp method. When I find a link it end up in a 404 error.
I’ve got the .bat files OpentftpServerMT and the Dualserver along with the other files needed to setup the tftp. But there is no good writeup. I read that you need to set the PC ip address to 192.168.0.1. But that is my router address. Also my network has a different ip address group. Does that mean that I use a single network cable from the PC to the My Cloud? Is the process different for a gen1 vs gen2. What I would like to do is test a new kernel without having to mount the disk on a different system to install the file. I intend to test the process with the current software. Once I know that it works then I will try a new kernel. I’ve been able to build both a gen1 and a gen2 kernel. I would have thought that the file size of the new uImage would be that same as the current uImage. But it is different.
Any help would be appreciated.

PS while trying to test on a gen2 system. I tried reboot halt and poweroff. Each caused the device to reboot. But when it got the the press any key it didn’t stop. Also for some reason each time it didn’t display the WD in big block letters.

tftp method . Do you mean the tftp method to overwrite an installed firmware?

My experience doing it with routers indicates you need to do this with just a cable between your PC and what ever hardware you’re trying to overwrite, set the PC’s IP address to a static IP that is in the same range as the default IP address of your external hardware, then fire up tftp to send the new firmware as soon as a connection is made.

If this is what you want, and you need more details, let me know and I"ll find some links.

Note also that the default IP address for Gen2 (at least) is something off-beat. I had to use nmap to find out what it was.

So,

Only for Gen1 deviecs: Recovery package and TFTP boot
As well as it is told above - it is necessary to connect the device to the computer directly.

For Gen2 device different method (More easy, but work not all time… idk why.): USB Recovery for Gen2

I don’t want to overwrite the current firmware. I just want to have the device boot a different uImage for testing. I understand that I can overwrite the firmware using different methods. But if the uImage is bad you brick the device.
From some of the information that I have found on tftp. They download uImage and uRamdisk and boot from the uImage. This method does not appear to overwrite the uImage in /boot/boot on the gen2. Not sure if this also will work for the gen1. If the system had grub you could just add the new uImage and select it on boot. If it failed then you just rebooted and selected the image that works.

PS I forgot to say thanks.

Thanks. I’ve used both of these methods to install a new HDD. I couldn’t get the USB to boot. But the alternate method did work.

I’ not sure if this is why the gen2 works sometimes. But in the u-boot the boot_delay is set to one second. I was able to get the gen2 to stop during u-boot. Listed the commands and the environment variables. So you have to be quick to get it to stop. But I also found that even if the boot_delay was set to zero. You are still able to stop u-boot using ctrl-C. Havn’t tried this yet.

For WD u-boot works only “Press [1]” (Number) at any time or continues.

Hi everyone,
I tried to fix my WD My Cloud Mirror (gen 1) by TFTP method.
I followed instructions from @Fox_exe (thank you!) but I am stuck.
I can see the ping window (pinging WDMC) and there are messages in the DHCP window as like instructions.
However, the TFTP window is still waiting/listening…
Front LEDs are red (flashing). What else can I do? Please help.

Thank you very much.

Finally I fixed my issue.
I have been searching and reading this forum for days and have tried various methods suggested.
Thank you very much for all the wonderful ideas and information!

Cheers,