As you can see I’m new to this forum, so forgive me if I don’t explain my problem too well.

I have the 3tb wireless drive, which my laptop finds no problem. The problem occurs when I try connect with my laptop via my phones wi-fi hotspot (tethering), my drive disappears off the list of available networks. As anbody else tried accessing their drive while using phones data connection?

Sorry for the rambling post


What method do you use to reach your Personal Cloud Storage device? is it the Western Digital Personal Cloud Storage service remote connection https://www.wd2go.com/ ? Or is it by means of Local Area Network access and your list of local devices?

I think it’s by the latter “Local Area Network access and your list of local devices” I’ll try to explain my problem better, sorry

I use a database program (OrangeCD) to catalogue my record collection. To enable playback of tracks, (which are stored on my MyBookLive drive) I have to copy the album path ie \MYBOOKLIVE\Public\Music\Killers\Mr Brightside. If I use just the laptops wi-fi connection everything works fine, it’s when I switch to my phones data connection (tethered) that the drive does not appear in the list of networks.

As I said in my previous post, sorry for rambling with my question, but it’s the only way I can (try) to explain


If this is the case, then this is expected. When you are using a mobile device as an access point then it is using the mobile device’s network, which does not communicate with your NAS as it is on another network. An internet connection and a network are separate.

On those cases, if the mobile device is supplying an internet connection to your system, then a remote connection by means of www.WD2go.com should still be possible.

Thought I’d try your suggestion, but when I click on the link you posted I get this!!


What’s happening there?


If www.wd2go.com/ redirects you to the Oracle website, then it meas JAVA is either not properly installed/updated/configured/enabled for your internet browser.

Our remote cloud service requires an active JAVA plugin.

Got Java working, but still no joy connecting to my drive. I can do everything else i.e. surf the net, watch youtube videos & so forth. But I still can’t see my folders so I can’t give a path to play my music. When I switch back to the VirginMedia network the drive & folders reappear


Do you happen to encounter the same issues using a different internet browser to establish the connection? Please note even if JAVA is installed, a JAVA plugin will request to allow access when you access the site. If the security prompt is not allowed then a connection may not be possible.

Tried using a different browser still no joy, Would it be possible to send a screenshot of the 2 different connections I’ve tried? Also to play music from my device with the laptop connection I don’t have to go on to the internet, I just use the built in wi-fi.

Sorry to be such a pain & I’d fully understand if you give it up as a bad job, but you’re help & patience is VERY much appreciated. I just wish I could explain thigs better!!