Terrible product or just unlucky?

Help please!!

new to this forum and get help anywhere else as it is the weekend…

First problem: my file transfer rate is between 200kb - 700kb p/s. Not really good enough when I bout a 2 TB drive because I have a lot of data to centralise. Has anyone else experienced this & got any recomendations?

Second problem… I cannot log onto the WD connfigure as everytime I put a password in it adds between 2 - 10 characters on the end. Does anyone know is happening? I have tried this is Google chrome & Internet Explorer and both do the same thing. I have deleted history, cookies, auto-complete options and yet it is still doing it. This is very important as hoping new firmware will speed the drive up?

I cant even tell you what version I am on as cant get access to the site for reasons above.

Please help…



First are you wired or wireless from your computer to the unit. The adding of characters is normal on the password, I use firefox and ie with no problems. If you have not set up the unit the pw and user are admin, Have you tried running the setup software or you can do a soft reset to reset the password  back to default. The speed thing dependent on your routers though put. I hope this helps you. M


Thanks for the response.

I am on a wireless connection. I have tried connection the network cable to the pc rather than the router, but the pc couldn’t see the drive if i did this. Am I missing something?

Also, how do i do a soft reset?

Will this loose the data I have already put on the drive?

Thanks in advance.


I get a maximum of 2 megabytes per second on a Wireless G router. I’ve read most others won’t get much faster than this with this drive via Wireless G. I get 10 megabytes per second via ethernet cable.

Is anyone else using your network? That will slow things down.

This what the manual says about the reset button:-

The reset button restores configuration settings such as the network mode/IP
address and admin name and password to default factory settings without erasing
shared folders and volumes. For more information on how to reset the system, see
“Resetting the My Book World Edition” on page 173

You will have check the ip address for your computer when connected to the wired network. If you are using windows 7 just click on my network and it should find it.

I have tried this “soft-reset” and I still can’t log onto the hard-drive as it is still adding random characters after I hit log-in.

Very frustrated!


Has anyone managed to connect the harddrive to the laptop directly or does this have to be done through the router?



Good question

You can connect with the unit using a network cable see below this is from page 175 of the manual.

My router has failed or is not available. How do I access my data in the device?
Do the following:

  1. Connect the device directly to the computer’s Ethernet port.
  2. Launch WD Discovery Tool and see “Mapping a Network Drive” on page 75 for
    instructions on how to access data in the device.

What password and user are you using as I said before It is admin in both fields. Also as before mine puts in extra  characters but still works. M

The WD discovery tool has never worked on my device, from two different laptops running Win7 and XP.

ok, I will try the wired connection tomorrow when I am not transfering data and see how I get on.

As regards loggong onto the drive.

After the reset I notice if I put admin, admin it doesn’t say error but just takes me back to the same screen. If type anything el;se its the same screen but with a username/ password error.

Very VERY confusing!

Also, i think your manual is different to mine as my PDF manual only has 150 pages.

Any ideas!?!?!

Thanks for the help thus far!


Below is the link for the manual it is 198 pages.


Good luck M