System will not read this Hard Drive

I purchased a Western Digital - Factory-Refurbished My Passport Elite 320GB External USB 2.0 Portable Hard Drive - Silver last week from Best Buy online. Today I received it in the mail. I hooked the USB cable to my computer and the system was tempting to download the hardware when suddenly a message occurred saying that particular Hard Drive did not have the XP logo on it. The software I use is XP and looks like it is not compatible with piece of junk that was a waste of my money.

Can anyone tell me what are my options?

What is the exact message? If you’re not satisfied return it.


Well , let me make it more clear to you. If I keep it this hardrive is there is any solution other than returning it.  I don’t undestand why Western Digitial did not make this particular model hard drive compatiable with Windows XP. 

I was on Best Buy website and the requirments were that be for Mac or a PC. Said nothing about  not be compatiable with Windows XP.

Clear as mud?

Well that product is compatible with XP. Look at the specifications

If you are having issue with it then you should do your windows updates. Be a little more specific about the error your receiveing what is the exact problem?

I asked you what the exact message was I’ve never encountered the one you posted. What version of XP and which service pack? Is your Windows up to date? Is this a genuine or hacked version of Windows?


My computer is HP Pavillion running a legit standarded verison of Windows XP. Last night I upgraded to a Service-Pack 3. I thought that solve the issue but hasn’t unless I’m not doing something else right. Also my system does not detect WD External Drive. It did at first and that when I got the error message that this drive does not have the Windows Logo on it. When I plug the USB Cable I hear a bell noise but it still does not read this portable drive.

Did you look and see if there was new software for this?  I only found 2 instances of this message  and It appears to be come type of software compatibility issue.  It’s really strange.  Did you try calling WD customer service? If they can’t resolve it I’d send it back. You might also call Best Buy and see if they can help.


Please check the following.

1)      Check the USB cable connected properly: Drive Side micro USB plug seats fully so you should not see any space between plug and the drive housing.

2)      If you hear bell sound while connecting the drive that is a good sign.

3)      Now “right click My Computer icon and select properties”.

4)      Navigate to device manager: Under “Disk Drives” you should see WD XXXX drive listed.

5)      If it is not listed there, your disk drive driver is not loaded and you have a hardware/connection issue.

6)      Try on a different PC.

7)      If your drive is listed on Device manager and still cannot see in the Windows explorer/My Computer means, your driver is either not portioned or drive letter is not assigned.

8)      If this is the case, right click on My Computer icon and select “Manage”. Please note that you need to have Admin privileges at this PC. (On some Windows PC’s you cannot install USB devices without Admin privileges.)

9)      If you are able to open “Computer Management” console, look under “Storage -> Disk Management”. Double click Disk Management and wait for awhile.

10)   Now you should able to see Disk Drives installed in your system on right side of the window.

11)   Look for Drive name e.g. WD… My Passport or similar… named or disk drive with capacity closer to your USB drive size. You’ll not see nominal drive size here. For e.g. 300 GB listed as 270 GB or similar.

12)   If you see a drive without drive letter/drive name, you can assign a drive letter by right clicking blank space of the drive and choosing “change drive letter and path”. Assign a drive letter available from the list. e.g. “D” onwards.

13)   If you cannot assign a drive letter means the drive is not partitioned. Right click the correct drive and create a partition of your liking, format with NTFS and assign a drive letter.

14)   Now you should able to see your WD Passport on your windows explorer.

15)   Again please note that, by creating partitions and formatting disk drive will delete what ever the software installed in this drive. So double check each step… and be careful not to format a wrong drive.

Good Luck.

1 Like

Thank you Mabkay I followed your advice and under Disk Drives and listed External HD with caution sign next to it I clicked on it and the system did a search for it and located and now it works. It back up information as I type this message. Your a genious

I also would like to thank everyone else that responded to my question. God Bless all of you!

Mabkay that’s a nice trouble shooting list.


I (live in England, UK) Bought mine (an actual new one from Comets Store) in the UK about November / December hardly used it .  Contacted WD’s Technical Tel No: 0080027549338 virtually useless. The above solution doesn’t work…  To shorten a long explanation; Error Code: 22 keeps on reoccurring.  This is despite that I have consistently tried to enable it.  The external drive appears to be reading and writing data correctly but the default D:\ is not displayed by my computer and some kind of writing error either to or from the external drive.  I am using Windows XP Pro. I have also used Microsoft’s, ‘Fix it’ diagnostic software - besides other things:

I am about to try the various steps, which WD’s e-mail Technical Team has sent to me and hope that reinstalling the smartsoftware etcetera doesn’t corrupt my data, because at least 99% before C’s drive was automatically formatted when I reboot my PC using Windows XP Pro Disk.

Interesting, it is beginning to appear that contra to the hype that too many Western Digital External drives have got the same or similar design faults.

The problem in my case is that probably at least 99% of all my data is stuck on the Western Digital Passport Essential external drive, which means that I have to be able to restore my data back onto my C’s drive and then I shall return it because I have rarely used it and despite the hype it is useless, which WD must now be fully aware of.

In theory Windows Update should solve problems, but usually have to then go to the relevant manufacturer’s website to download drivers in this case WD’s website.

Probably the best place to give an indication what the problem is go to Microsoft’s, ‘Fix it’ website. It didn’t solve the problem, but gives a better indication of what is causing the problem. Select RUN. This forum wouldn’t allow me to copy and paste the web’s address.  Try searching for, ‘Your CD or DVD drive can’t read or write media’ may find the same web’s page.  I think that I managed to copy the website on one of these forum’s threads, but can’t remember which one.

In my situation I am using genuine and up todate; Windows XP Pro (version 5.1 and Service pack 3), and everything else is also genuine (otherwise for example MS won’t allow Windows Updates).

The external drive, which I have is the Western Digital Passport Essential USB2 & USB3 attach to a stand alone computer using USB2.

In my case one of the error messages is called Code: 22, which Microsoft (MS) claims is due to the drive being disabled, but the problem is that it is impossible to enable it. 

The nearest thing to finding out and solving the problem is Microsoft’s ‘Fix it’ diagnostic software even though it doesn’t actually solve the problem.

Unfortunately, this forum won’t allow me to copy and paste the web’s page.

The principle problem is that I have about 99% of my data stored on this useless external HD, which I cannot resore or retrieve onto my C:.

It appears that WD has been fully aware of what is probably a design problem.

Before I forget WD Passport Essential appears to be reading and writing correctly due to the flashing light and lack of error messages.

First, you should have started separate thread for your issue.

Anyway, please read my technical guide here to resolve your issue. I have addressed lot of avenues which contributing to USB drive issues.

Follow this link

1 Like

This looks like a good post I’ll study it when I have more time. Thanks!


Thank you Joe_S …:smiley:

hi, ma problem is, that no bell sound appears, when i plug the drive in, an no items listed in storage/disk management. since yesterday … i do not understand this. but i do not think, that the device is broke, because it sounds normal and the led shows idle blinking …

Though very helpful, I have been unable to see the WD drive in Computer management. What is the next step?

Julie Anne