Synology OS on WD my Cloud - new Hope

DSM install on V1, was only possible as external usb HDD on a linux machine, ssh/tftp didn’t work (worked for OMV) Any how, works now with your instructions Fox_exe.

For tested i can add:
Network file access:
Apple: Ok
* Read: 40-50MBps
* Write: 20-30MBps
Timemachine backup ok

What don’t work for me is USB printers and USB HDD don’t show up in external devices?
Thanks for the great work!!!

USB not work - not support in kernel (Need edit USB drivers).
If someone have Gen1 and UART adapter - i can try make new kernel and DSM6 for test.

I have a Gen1, without HDD and only a USB2Serial adapter.
But isn’t shipping to expensive?

Does anybody know if the gen1 and gen2 are both 64k pagesize?

RAC

Gen1: MMU / harware support “Huge pages” (Memory page size = 64kb).
Gen2: Sofware-emulated 32kb support. Compatable with default 4kb apps.

Will this work with any WD MyCloud device? I have a DL4100 and would be interested in running something other than the limited buggy MyCloud firmware.

Nope. For DL4100 need different kernel.
Buy UART and call me in Skype - i try to make kernel for this device.

UART? What is that and what is your skype UID?

UART (Universal Asynchronous Receiver/Transmitter)

Thanks SectorGZ for the information. Greatly appreciated!

Thanks for all your effords Fox_exe! Looks very promising. As soon as a USB drive will work with this DSM Port I’ll give it a shot :slight_smile:

Great work from Fox_exe, Thank you. I have a 8TB Mycloud Gen2. It works booting with the USB, but then fails to initialize the Harddisk (e.g. should erase previous myCloud partitions). Error 35 . It seems that the WebAssist from the USB Stick is not capable of handling my harddrive. The error comes BEFORE the upload of the *.pat file , therefor something in the USB “Web Assistent” must be causing this.

So I tried to get into TELNET , with the Password Generator… I had to load the *.PAT file via the Synology Assistent, then it claims I should open a port 23 (Telnet) for the Support. Telnet now works. Unfortunately it does not accept User “root” and the generated Password or the 101-0101 for “no date”. Todays password would be 707-0b01 .

Is there something in the USB-Image changed, so that the default date is not 1st Jan 1970 , or the user / password combo is changed? Will there be a DSM6 USB Bootstick Option some day? It would probably be able to handle my 8TB drive. My device is seen as DS115 , which seems ok for Gen2 MyCloud.

BTW. I want to change my drive to DSM so I can use iSCSI for ESXi VMware.

UPDATE

In another thread I found it! “User / Password for login (WebGui, SSH, etc…) is root/mycloud or admin/mycloud” . It worked! It tried to mount /dev/sda1 , which did not work. So I “dd if=/dev/zero of=/dev/sda count=1024 bs=1M” and it went on with installation, asking whether I want to migrate my data or make a fresh install. I choose “fresh”.

Thank you!.

Does it work on MyCloud EX2 (non ultra) ?

Is there a way to upgrade DSM 5.2 running on WD MyCloud Gen1 to DSM 6.x without reformatting drive currently?

Hi,
I have tried to install the DSM on my WD my book gen1. I followed the insctruction but when I reached the tftp command the system says:
-sh tftp not found
Can you advise why this happenening?
Thank you in advance

Hello,
Please contact me how to install to my wd My Book Live Synology NAS OS.

Hello Smark777
Did you got an answer to install to your wd My Book Live Synology NAS OS ?
Because i’d like to do the same thing
Regards
Jean

Hello my friend.

Could you help me on a quick guide for upgrading my WD MyBook Live 1bay 2TB into a Synology Station ?

Thanks you in advance for your helpand Support,

kind Regards,

Dimitris

@Fox_exe
I need help i used the tutorial for MyCloud Gen1 Single Bay http://anionix.ddns.net/WDMyCloud/WDMyCloud-Gen1/Synology_DSM/_howto_install_en.txt

Everything was working and: http://IPADDRESS:5000/web_index.html shows me the Synology Web Assistant that asks me for a .pat file which is not in the file archive… help pls <3

-Dan