Syncthing with OS5

I had used my WDMyCloud with OS2.xx.xxx and Syncthing for a long time. Now I want to update to OS5 and I am looking for a fitting version of Syncthing. Can anybody help me ?

The SyncThing app is available on OS5. Got it installed on my NAS.

image

@Myron
Which My Cloud device (NAS) do you own.

I have a WD MY CLOUD 2nd generation WDMyCloudImage

Here’s what shows under Apps on mine.

Possibly see this discussion where there appears to be a OS 5 Syncthing download link.

[PACKAGE] Syncthing for WD My Cloud
https://community.wd.com/t/package-syncthing-for-wd-my-cloud/235360

The WDmyCloud units - like what you have - have been proving VERY problematic with the OS/5 upgrade. Bricking seems to be very common.

Proceed with extreme caution.

Your odds of success would be greater (but still not great) if you DISABLE ALL CLOUD SERVICES.

Hi Myron, thank you for your reply. Have you got any link for the download. The link https://api.bintray.com/packages/tfl/wdpksrc/Syncthing/images/download.svg?version=1.11.1 does not work (forbitten)

1 Like

Hi NAS_user, I did the same. After disable all cloud services und configuration of the new Twonky Server everything works fine in my private network. The access seems to be a little faster with OS5.

My head’s not working right this week. I forgot that I didn’t get it from the WD store. I downloaded the apps from bintray for my DL NAS before bintray shut-down.

Have you tried contacting the developer/host (user @Tfl) directly to see if they have a new hosting location for the OS5 version of Syncthing?

It appears there may be a email address for that person at this link: https://bintray.com/tfl

It appears the individual also has a Github page: https://github.com/stefaang but they haven’t loaded the OS5 Syncthing version 1.11.1 to it. Rather an older version for OS3 is there: https://github.com/WDCommunity/wdpksrc/releases/tag/syncthing-v1.3.0

I am aware, normally this weekend the links should be back up on Cloudsmith.

1 Like

Thank you for that information. I’m looking forward to find the link on Cloudsmith very soon

1 Like

I am a newbie here, trying to configure my first WD EXT2Ultra from yesterday.
What I understood here, the ready-made build of Syncthing 1.11.1 is no longer available in jfrog. So, I compiled the binaries from the github source code.
Now, I installed Syncthing on OS5 and it is running super-smooth.

I suggest to freshly compile from the official git from wscommuniy. If you feel it difficult, you can download the binaries from my repository (however, I don’t recommend downloading and install code compiled by unknown folks)

1 Like

Hi, I’m a newbie, too! Can you explain how compiling from the official git is made?
Thank you in advance! :slight_smile:

1 Like

Take any linux machine with docker.io and docker-compose installed.
Also make sure libxml2 and openssl is installed,

apt-get install docker.io docker-compose
apt-get install libxml2 openssl

clone the repository GitHub - WDCommunity/wdpksrc: Cross compilation framework to create native packages for the Western Digital My Cloud to a folder and cd to that folder.

git clone https://github.com/WDCommunity/wdpksrc.git
cd wdpksrc

Then build and run the docker container from following commands,

docker build -t wdpk .    
docker run -it -v $(pwd):/wdpksrc wdpk /bin/bash    

Now you should be inside the docker shell

cd wdpk/syncthing
./build.sh
exit

You will see a folder created named packages/syncthing
You will get what you are looking for inside this folder.

Instead of syncthing you can try any other package.

2 Likes

bintray is closed. where are now the various packages that were there

1 Like