HI I have read the instructions and tried using the synch buttons for 3 livewires but for the life of me the WD utility always only shows 2 devices detected? And one has a real good speed (150mbps) and the other **bleep** around 30-50mbps. When synching 3 devices together shouldnt all 3 show up in utility or only the ones not hooked up to the router? Livewire works great in a pair and was pleased but boy adding the 3rd has been more difficult than I thought it would be. I must be missing something.

I do the synch button on all devices each less than 3 sec and all within 2 min and get the green synch light on them but it blinks now and again. Not sure if it should be steady green. And then doesnt show all 3 devices in the software utility being detected.

I wonder if since I was trying to synch 3 and not 4 that causes the problem. When I get home Ill try synching all 4 instead of just 3

Well at least 2 device show up on the WD utility but odd all three I wanted to synch are synched and seem to be working. But the livewire hooked up to the router doesnt show in the utility to see its current speed and unable to enter its password but was able to enter the password for the other 2. I want all three passwords so I can create a private network.

On another note I get 188mbps on  the device upstairs but the one on the other side of the living rrom from the router is only 62mbps. Might as well go back to wireless at 130mbps. Wonder why such a speed difference

I you have 3 livewires connected, one should appear on top, below the “Local devices on your computer” and the other 2 below “powerline devices detected”.

I have to look and see which ones are listed when I get home. Does it matter which computer you installed the livewire utility on? I dont have it installed on the one where the router is.

shouldnt the livewire hooked up to the router run at 200mbps? since it is directly connected to it

Did you add the third LiveWire by using the “add” button in the utility and then typing in the password found on the bottom of the livewire device? I don’t know if the sync button works for more than the first pair. I currently have one base and three recieving units.

I used the synch buttons. But then I tried entering the passwords and for some reason one of the 3 boxes the password doesnt work (box hooked up to the router)