Switching HTTP access off in favor of HTTPS for EX2 Ultra

Hello,
I seem to be unable to switch on HTTPS access to my EX2 Ultra web interface. I can only access it via HTTP. Security is important to me.
I have enabled “HTTPS Redirect” under “Web Dashboard Services” but it does not seem to do anything.
How can I disable HTTP access to the web interface and enable access via HTTPS please?
Thank you

Hi,
What version are you running?
On OS5, it has to install a (let’s encrypt) certificate and takes some minutes I think and then do the redirection from the local address.

Hello, I am on OS5. Do you have a link to a tutorial for this please? Or to anywhere that describes how to do this.