Swaping WD Red Drives in MyCloud EX2

Quick question from a novice here… I have 2 WD Red drives (3T) installed in my MyCloud EX2 enclosure configured in RAID 1 mode (mirrored). For extra backup safety, I wanted to buy a third drive that I will swap in and out periodically (every month or so), storing it off site in a safe location. Two questions:

  1. What do I have to do to format my WD Red Drive to be recognized by the MyCloud EX2?

  2. When I swap out the drive and replace with the new empty drive, do I need to take any action to create the mirror or is this automatic?

  3. Similar to question two, when I replace the old drive back in the enclosure in a month or two; what do I have to do to make it sync with the active drive (and make sure it does not happen vice versa; i.e. it syncs to the old drive and not the most recent version

Thanks for your help with questions from a newbie.


That is not really what RAID 1 (mirroring) is really intended for. It is to provide redundency in the event of one of the drives failing.

What you are describing is really backing up the EX2. This is better done by buying a USB 3, external 3TB drive, plugging that into the EX2 and using the built in Backup utility to backup the contents of the EX2 to the external drive. You then unplug that and store it safely.

Messing around with the mirrored pair in the EX2 to try and do, what is essentially just a backup, is inviting things to go wrong and result in loss of data.

I do exactly the above with my 2 x 3TB EX2.

Depending upon how much data you actually have, you could create a new backup folder on your external USB 3 drive every time you do a backup, so you maintain multiple backup copies, all without messing with the internal drives.


Thanks for the information George, good advice. I have canceled my order of the new WD Red drive. I have however been struggling to get the USB function working. I have tried to connect the USB to transfer files, as this is supposed to be much faster than the network option (particularly WIFI), but this did not work for me.

Following your advice, I have been trying to use the backup utility to backup the data on a 3TB WD Passport drive, but it seemed to get only 1/10 of the way through and then it seemed to hang up and make no more progress. Do I need to keep the control panel open while I am doing the backup? Does the computer need to remain active, or once the request is sent, does all of the action take place between the server and the usb drive? Again, thanks again for all of your help with my newbie questions.


How much data do you want to transfer? A few hundred GB or more then a TB? Start the USB Backup job and wait over night. First backup took 2,5h for 300GB here. Next backups are way faster if you choose to synchronise an not to copy all files. If you think the backup hangs take a look at the EX2. You can hear if the drives are working or just spinning. And you can see high CPU load in the Dashboard if the Backup is still working. The Backup runs without any computer…


I am backing up about 1.7TB. I have tried 5 times now; each time, it gets to about 90GB and roughly 35,000 files and just appears to stop; and not go any further. I have let it run overnight and once for two days, it never gets past this. Any ideas? Beginning to wonder if I have some issues with the unit. I am going to reboot and try again tonight. Any/all guidance is greatly appreciated.


Hi Wes,

What “mode” are you setting when you create the backup job? I have an outstanding case (one of several) with WD Support about backups. If you create a backup job using “Copy” mode then I (and other users) have found it will get part way through then just appear to stall. In my case it is usually (but not always if I try a different set of folders to backup) after 184GB.

The symptoms are the backup appears to still be going, but no progress in the Dashboard, and all HD activity on the EX2 and the external USB drive has stopped - mine usually go to sleep.

What I have found is it WORKS, if when creating the job you set the backup mode to “Synchronize” and select an empty folder on the USB drive as the destination. Give that a try.

Just tonight there have been some interesting developments when I was doing some further testing for WD Support while checking the progress of the backup in an SSH session to the EX2 - using a command they supplied. That showed that the backup clearly had bombed with a “segmentation fault”, even though the Dashboard said it was still going (another problem logged for that).

Anyway, give the backup another try using “Synchronize” mode instead. Works for me!