Support tells me it could be up to a week to fix

I mistakenly had my 3TB MyCloud set to auto update firmware. I have a computer backup system called SyncBackPro that auto runs when I shutdown my computers, It backups up specified files to a share on the MyCloud. Yesterday I noticed that all backups had failed with the error “timed out”. I tried to log onto the MyCloud and could not access the user interface… I power cycled and after about an hour the interface appeared but it kept timing out when trying to add the username and password. Today I contacted support and they tried to help me by connecting the ethernet cable directly to a PC, power cycling, pressing the reset for 4 seconds and finaly pressing the reset for 40 seconds. Now all I get is a steady white light on the front of the MyCloud… I am unable to access anything. The MyCloud doesn’t show on the network anymore either. The support agent says that WD will contact me again within a week or so when the firmware guys have a fix. He gave me a case reference number just in case they fail to contact me. I fail to understand how firmware will fix the drive when I am now unable to connect to it. I did mention this but was told that they have ways and means.

I have no confidence with the help I was given and now realise that there is a good chance that my backup data may be lost too.

I think a week is a long time to wait for a answer. In the meantime I am going out to buy a Synology disktation to backup my PC’s, they gave reliable service, only having to be replaced when their capacities were getting low.

Please help WD, your reputations is going down in my estimations

So I went out to buy a Synology diskstation to replace my inaccessible 3TB MyCloud so that I may undertake computer backups until support get back in contact with me. Unfortunately I was unable to find stock in my area so I came home with a new 4Tb MyCloud, which I will make sure the auto firmware update is disabled. At least I can feel secure in the knowledge that my computers data is backed up.

I was then a little dismayed to find that people who are having problems with their drives are being blamed by WD for installing apps and messing with SSH access. I have never done this and only use the drive for saving backups and retrieving the data remotely. This seems dreconian to me. There are obviously a certain percentage of users that have problems after the firmware update, and a percentage of those who have not ‘messed’ with their drive. Perhaps WD could survey these users and perhaps ask for serial numbers to see if it is a certain batch of drives that show the problem.

I own quite a lot of WD product and as I say I have bought another MyCloud today even though my unit is still under warranty but I wasn’t prepared to wait a week for support to action this further. Perhaps Bill_S could escallate my problem and try and get it resolved in a more seemly timescale, as he has done for others.

Peace & love


Please see your personal messages.

Bless you ERmorel. Your assistance is appreciated.

Allertoner said, I have similar problem, so I’m willing to ask, what was this message, and can you send it me too, if any…?

ERmorel wrote:



Please see your personal messages.

ERmorel has escalated my fault. Not heard anything else since Friday but that may be because support only work week days. 

Please help !!   ERmorel

  1. Did FW update.
  2. no dashboard, no ssh,
  3. Presesd reset button.

Now no dashboard, no ssh, no idea how to fix it.