Support for 8TB My Books via USB on My Cloud Gen1 / Gen2 / EX2?


I have a My Cloud 4TB Gen1 with 4.x firmware for several years now.
I had several My Book 4TB connected to the My Cloud over an active USB 3.0 HUB.

Please no comments on this setup, I know its not the ideal way to extend the capacity of a NAS but it worked flawlessly for years. And it suited my needs completely.

Lately I exchanged some of my 4TB USB drives with 8TB My Books of the latest generation.

And this is where the trouble began. After a few days of use I got file corruptions on those drives. Resulting in files and directories not being accessible anymore. Even WD Diag could not complete its tests on these drives anymore and reported them as faulty. I had to reformat these drives on my Windows PC to make them work again. (After reformat WD Diag completed extended tests withouth any issues).

I repeated this scenario one more time with the same result.
This leads me to the conclusion that My Cloud Gen1 can’t adress 8TB USB drives correctly and overwrites existing data with new data send to the NAS over network.

Yesterday I got a factory refurbished My Cloud 4TB Gen2 from WD with FW 2.x
This device works fine with my 4TB My Books but refuses to mount the 8TB My Books at all.

Log message looks like this:
Unable to Mount USB Device
Unable to mount the USB device (vendor: Western_Digital, model: My_Book_25EE, serial number: XXXXXXXX). Please check the USB device.
Tuesday, 16 July, 2019 22:19:42
** Code:1124**

So, am I correct to assume that the My Cloud Gen1/2 don’t support 8TB external drives?

What about the My Cloud EX2? I could get one for an interesting price.

I couldn’t find any reliable information about the max. supported drive size for external USB drives for the My Cloud devices. Maybe someone can help?

I have My Cloud with and 2.xx firmware.
My 8 TB My Book (the one that looks like a black Lego) would not mount if formatted NTFS with my newer Windows 10 Acer Asphire laptop. However, I reformatted NTFS using old Windows 10 Dell and then again with old Windows 7 Acer and had no issues. Not sure why the new Acer Windows 10 NTFS format does not mount, but you might want to format using Windows 7 NTFS or macOS HSF+ if you have mac.

Thanks for your input. :slight_smile:
I don’t think that’s the case. The drives are encrypted so it can’t access the file system.
But it doesn’t get to that point. My 4TB My Books are encrypted as well and My Cloud Gen2 had no trouble to ask for the key and then mounting them.

So, don’t get me wrong, but I really don’t want to wipe and refill 8TB of data just on a hunch. :wink:
Also I only have a Win10 machine at my disposal.

So your drives are encrypted and when you attach them to the My Cloud, you don’t get that little unlock button thingy in the dashboard? I think I’ve seen someone post something similar somewhere…cannot recall. Are you on the latest firmware?? 04.05.00-334 (03/12/2019)

Have you tried removing the password encryption and see if the 8 TB mounts?
Have you tried an unencrypted flash drive?

In addition to the suggestions above, also check that there is one single partition on the external hard drive. Seems some single bay My Cloud units have trouble properly mounting an external hard drive if there are two or more partitions and the main data partition is the second (or later partition) to get read by the My Cloud mounting code.

And try using a third party formatting utility to format the drive as a troubleshooting step rather than the built in OS formatting feature.

Also, on the security encryption, I had though the single bay units didn’t support that option on external drives but that might have changed with later firmware.

On Gen1: all drives (4TB & 8TB) show up under the USB icon. And I can unlock them by clicking on those little keylock icons.

On Gen2 with latest 2.x firmware: 4TB My Books behave the same as with Gen1 above. However, 8TB My Books don’t show up under USB icon, but show up under the LOG icon with the error message I quoted in my first post. I don’t know if that reported code: 1124 means anything. I can’t find any useful information on that.

I also tried to connect each drive directly to the Gen2 instead of using a hub. But results are the same.

1124 is a USBBadSmartStatus
look at the file /etc/nas/


Password Protected My Book not Detected by My Cloud - Unable to Mount USB Device

Great find socallinux! :grinning: That seems to be the reason.

And it’s hard to believe and understand why they are UNABLE to support features of their own drives with newer My Cloud models.

I bought a My Cloud EX2 in the mean time. The same firmware version as for the Gen2 My Cloud should’ve been a warning. But I wasn’t listening. It behaves the same way as the Gen2.

Seriously WD? Gen1 My Cloud is able to unlock those My Book drives, but Gen2 and the much more expensive EX2 not?

Again my opinon about WD is confirmed. I’ve been using WD drives for almost 30 years now. They build excellent drives but their Software is unbelievably bad at times. :frowning:

Using my drives without security enabled is absolutely NO option to me.