Summary of bugs found in 1.04.17_V firmware


#1

This are the bugs i’ve found so far, I’ll be adding more as soon as I find them:

  • Info overlay keeps displaying after skiping chapters in dvds, you have to press enter twice to hide it.

  • Can’t login to facebook sometimes but once I get connected the device restarts if check newsfeed

  • If audio output is set to “digital” there is sound from the tv only playing dvds (iso or video_ts folder) with 5.1 audio but no sound playing mkv, m2ts or other files with 5.1 audio.

  • Shuffle/random music does not play entire library.

  • Photos don’t look sharp yet

FUTURE REQUEST:

- SUPPORT FOR MULTICHANNEL LPCM AND DTS-HD MASTER AUDIO PASS-THROUGH (ONLY DOLBY TRUEHD AND DOLBY DIGITAL PLUS PASS-THROUGH IS WORKING SO FAR AND ONLY PLAY THE “CORE” IN DTS-HD MA). 

  • Support for converting AAC 5.1 and WMApro 5.1 to LPCM 5.1 on-the-fly to play over A/V receiver with LPCM multichannel playback.

  • SUPPORT FOR 1080/24P AUTODETECT FEATURE

  • Skipping chapters in mkv files with next or previous buttons.

  • Support for USB spanish keyboard layout

- 4:3 videos stretched to 16:9

- Recently viewed (video, photos and music) on the home screen

  • Thumbnail support for MKV to show cover art embeded into file

#2

Strange why we not started this tread like in case of 1.4.10.

Please no discussion, just bugs with quote of bugs from ealier posts.

  • Info overlay keeps displaying after skiping chapters in dvds, you have to press enter twice to be hidden.

  • Can’t login to facebook sometimes but once I get connected the device restarts if check newsfeed

  • if audio output is set to “digital” there is sound from the tv only playing dvds with 5.1 audio but no sound playing mkv, m2ts or other files with 5.1 audio, however there is sound from the spdif output connected to a A/V receiver with dolby digital or dts decoding capability no matter what is playing.

  • While working few hours wdtv cannot login to deezer again (even login and pass was saved), it always  says abou wrong credentials, you need delete account and after it login again is fine.

  • Youtube plugin becomes slower

  • Menu navigation sometimes fast as on 1.02.21 but often so slow (wdtv composite connection)

  • While movie watching (avi xvid for example), press option - menu appears on audio channel selection icon but under it: no audiochannel, move to another icon and go back - normal info. Looks like same bug when watching few videos one by one (after pressing play on first movie) and on first one change zoon to 0.9, on second movie if i call option menu, it show zoom 0.9, but really it is 1x, after moving on another icon and back it show correct zoom info.

  • Users with wdtv that have another hw revision that ends on: NBK-01 have problem while choosing russian language, wdtv start jump between menu items, or on virtual keyboard jump between letters. In case english language all ok. Also it’s fine in case NBK-00.


#3

Since WD did not fix virtually any of the problems that we documented in the summary thread for the last release, maybe we can just document the new problems that we are having. Do we really need to list all of the same issues that we already documented in the previous summary thread?


#4

The 3 and 6 request is very important and must implement in the next firmwares.All need these updates.


#5
  •  there is a display bug when trying to switch audio track in multilanguage MKV files. The audio icon at  bar in top of the screen writes “No audio”,  but when pressing it - language switching normally.

#6

For the moment I can confirm a part of this this bug: “- Can’t login to facebook sometimes but once I get connected the device restarts if check newsfeed” In my case (wired internet connection) I have no problems with logging in but always when I check “newsfeed”, I get a restart of the box with complete reset of most presets. 1.04.10 seemed to be more stable – what has happened?


#7

-shuffle/random music does not play entire library


#8

Prev / Next do not work as expected. They do not skip chapters in either video_ts folders/dvd iso or mkv’s… they go to the prev / next video file.

The Home button doesn’t do anything, then multi level deep in a menu, this should bring you back the the home menu.

Default audio track in mkv’s seem to be ignored for dnla served files (tversity/serviio)

mkv chapters don’t work when using from hdd.

hi bitrate mkv’s stutter when using network shares.

Requests


Can we have auto refresh rate changes, play a lot of dvd rip at 50hz and mkv’s at 24hz.

Can we have control via IP

Can it be made to show metadata? one of the views shows cover art but can it be made to show metadata from something like a MyMovies type xml file, even use a background.jpg from a folder?


#9

wxchaser wrote:

Prev / Next do not work as expected. They do not skip chapters in either video_ts folders/dvd iso or mkv’s… they go to the prev / next video file.

 

You must have something wrong with your rips as chapters do work on DVD rips either as vob rips or .iso.


#10

The rips are fine, work in media centre, power dvd, media player and every dvd player when burned to test. 

I have just tried it again for mkv via dlna server and it jumped to the next file, not tried video_ts again since firmware update.


#11

wxchaser wrote:

The rips are fine, work in media centre, power dvd, media player and every dvd player when burned to test. 

I have just tried it again for mkv via dlna server and it jumped to the next file, not tried video_ts again since firmware update.

The prev / next buttons do not work on mkv chapters only on DVD rips to vob or iso.


#12

To add on Rich’s answer, to use MKV chapters you press the options button on the remote.


#13

I know that you can skip using the menu for mkv’s, still not re-tested on the vobs/video_ts yet. The argument is, it is a bug that the prev/next do not work as expected with regards to the icons on them. If you press them you expect to go to the next chapter rather than the next video file… and thats without going into a menu to see the chapter list.


#14

Remote next/previous-button doesn’t skip chapters in MKVs. (DVDs working)


#15

en sometimes buffering

i have in the future never had the buffering movies on streaming network (1gb lan network wirred)


#16

en sometimes buffering

i have in the future never had the buffering movies on streaming network (1gb lan network wirred)


#17

wxchaser wrote:

I know that you can skip using the menu for mkv’s, still not re-tested on the vobs/video_ts yet. The argument is, it is a bug that the prev/next do not work as expected with regards to the icons on them. If you press them you expect to go to the next chapter rather than the next video file… and thats without going into a menu to see the chapter list.

The prev / next means the prev / next video as it does with photos and videos and it is not a bug.

The manual states

PREV 

(previous track)

• Press once to jump to the start of the audio/video file. 

• Press twice to jump to the previous audio/video/image file.

• Press to page up

NEXT 

(next track)

• Skips to the next audio, video, or image file. 

• Press to page down.

• During Video FF mode, press to skip forward 10 minutes.

.

In DVD mode it also allows you to jump chapters.


Chapter Selection

If you are viewing a multichapter video file, you can select which chapter to play. 

To select the video chapter:

1. Press OPTION. The Options bar opens.

2. Highlight , then press ENTER repeatedly until the preferred video chapter is 

displayed. 

#18

iso blu ray rips are no working with this firmware version,when i try to play a iso blu ray it only play the main menu.arrrrrrrrrgggg i hope the new firmware can fix this issue.


#19

I don’t know if this bug is specific to this firmware (because I could’nt try with another), but tv lose HDMI signal if we change the “tv source”, more explanations here : http://community.wdc.com/t5/Firmware/HDMI-WDTV-Live/td-p/123726