Suddenly unable to mount My Book


#1

I have been using My Book studio edition successfully for months.  Recently I upgraded my OS to Snow Leopard.  My Book still worked until a couple of days ago when it was suddenly unavailable in the finder window.  Now, this is where it gets weird - when I look in Disk Utility I can see that the device is connected, and i have been able to run the verify disk and repair disk on it, but My Book appears in a subfolder under the folder for WD and it is greyed out.  Whenever I try to click mount it says that it is unable to be mounted and to run repair disk, which I have already done and it says it is fine!  I have tried this with both the USB and the Firewire Cable, as well as connecting MyBook  to a MacBook, but the same thing happens.  Somebody help, PLEASE!!


#2

Same problem here.  Or real close to it.  I got locked out of my drive via bad permissions.  I was able to recover all fils from Data Rescue.  When I went to reformat the drive Disk utility could not preform the task.  I cant do anything to the drive.  It was working fine until after tying to erase the free space.  Got me real puzzled.  Even tried to instal the WD  Turbo drivers.   Any help WD please!