Suddenly... Problem on MAC

Hey everyone!  :smiley:

I’ve been looking all around the internet but i didn’t find any solution of my problem, so maybe you guys can help me. 

I got an USB  WD Mypassport Ultra  since November (format: Mac OS Extended volume) and everything was working as well as I expected. I used it specialy for my  iTunes’s library, making me save a lot of my MacBook Pro’s memory.

I’m on OS X Yosemite (10.10.2)


It started having some trouble on February’s 1st while is was playing my music from iTunes (my library is actually located on my Usb Disk). 

It started to freeze after few seconds of playing, so I had to force quit iTunes. It did the same thing with the “quick look” from Finder. Copying started to have some “freeze” time too, getting longer to be done.

I opened WD Drive Utilities to check if everything was ok, but then I realize that the quick test and the complete test could not go ever 10%, then stopped and says that the test just failed.

Yesterday I got an “error code 36” while I was trying to copy some files from my Disk to my computer.
I was actually doing that cause I realized that I should thing about do some backup (I didn’t took the time to realize that already).
So I checked on forums what was code 36 and how to fix it.
I tried to use the terminal, but nothing of that changed anything.

Copying files became impossible.

I opened Disk Utility, check my Usb disk and then I had the following messages:
-The volume could not be verified entirely
-Error : This volume should be repaired


I tried to, but again I had bad news:
-The volume could not be verified entirely
-Error : Disk Utility cannot repair your disk, save as many files as you can, reformat the disk and restore your files.
After this part, my disk just get ejected.

Plugging it again, my disk doesn’t appear anymore as it did before (on the left on my finder), I have to open the MacBook source file to see it.

And that is where I am now:
When I plug my disk I always have a message saying that OS X cannot repear the Disk, that I can still open or copy files on the disk but that it is impossible to save on the disk any change did to the files, that I have to save the disk and reformat it soon as possible.

When I press cmd+i on the disk, here what changes I have:
-My disk format is now Mac OS extended (“journaled” mention had disappear)
-I can only read, I’m not longer autorized to write on it
-I also cannot change the name of my disk

I am first of all worried about saving my files,

I really don’t want to loose them (Music, Movies, Work)

I have an old USB drive I can use to put my files in it as a backup before to maybe after reformat Mypassport Ultra, but what should I do to make copying possible?

I won’t be able to enjoy and to work with my disk until I got a solution, so you help could be gold to me! 

Thank you


Hi and welcome to the WD community.

Try to use the drive on a different computer to see if you get the same issue, i would also try to use a different cable just in case and also a different port.  

Hey, thank your for you answer.

I did some reseach and I think the disk is the problem.

I just etited the post as you can see , and it looks like it does not come from my mac at all.

I don’t have another cable, and i don’t want to buy one just for a test, but i’ll try to test my disk on my old MacBook.