Suddenly can'd copy to SOME folders

I have a WD My Book Essential 3TB Hard drive plugged into a WD Media Player. I have been copying files to the hard drive wirelessly for weeks. I have 5 folders on the hard drive. Within these folders they contain more folders. All of a sudden I cannot copy to one folder (Pictures) of the main 5. No matter how big or small the file is it will not let me. It will not let me create folders within it and I cannot create folders in my main hard drive folder. Every other folder on the drive allows me to  copy as I could before. When I plug in my hard drive directly into my computer I have no issues placing the files where I want them.

Any idea as to why I cannot copy files wirelessly any more?

Then the problem would appear to be on the media player side. To be sure, you can run a test using DLG.

How do I run this diagnostic directly on the media player if that is the issue? I cant connect it to my computer. also, i only have a mac to work from. i ran first aid on the hard drive and there are no issues.

I have all my copies backed onto another hard drive. When I swap them out I have the same issues with the same folders.

I Cant find any solutions to this issue yet.