Sudden FREEZING Windows 10 file explorer, quiting WD Discovery fixed it

This happened yesterday. Everything that had to do with windows explorer started freezing or super slow. Saving files, opening file explorer, everything. (not specifically my mycloud home drive)
Tried every method online, cleaning cashes, disabling explorer features, I was getting desperate. Nothing would work. Rebooting made the explorer work normally for a few minutes, then trying to open it gave me a white loading window.
Out of nowhere I decided to quit dropbox, nothing happened. Then I did the same for the WD Discovery app from the trey icon, and instantly explorer started working again with no issues at all and it opens normally in about 0.01 seconds.

Anyone else having this issue or know if its a known problem? I dont have any pending updates (windows nor wd discovery)


1 Like

I get this problem regularly, it’s hugely frustrating and makes me worry about the stability of this solution.

WD don’t respond to requests for help, and I feel alone in the community.

Constant problem, it’s very poor software. I “exit” WD discovery until I need to access the drive. Only a problem on my Win11 machines, not on the Macs. The Macs have other issues.

A geek would probably post a screenshot of the task manager CPU or even a process explorer shot of the WD processes (wdsync, WD Discovery, kdd). If you are not running a background sync or copying files to and from the MCH, those processes would be nearly zero and Windows Explorer will not freeze or do any of that.

Most MCH home user make the mistake of syncing their entire My Documents and other desktop folders and then wonder why the performance is bad.

Another home user mistake is that most home users have slow upload speed so when they have Windows Explorer connected to a MCH remote or relay folder, they think that windows will behave the same as if the file folder was on their desktop with instant access. The home user should know that upload and relay server speed will often limit access to < 1 MBps and often slowed to <100 KBps and you have your File Explorer freeze right there if the user user tried to drag and drop many files.


Nothing syncing, nothing copying, nothing replicating, simply opening an explorer window regularly causes the problem, sadly randomly.

I’ve left it alone and eventually the folder opens.


Hi I’m having exactly the same issues tried what you did and Windows Explorer worked again. I have logged in again and it has not frozen yet.
Thanks for sharing.

1 Like

I have the same issue, it take some minutes for explorer to respond with every click within the mycloudhome window and hangs explorer yet my wdmycloud smb devices responds fine on the same network and same switch and router and same end device. And yes I switched ports and cables to ensure that wasn’t the issue, it was the first thing I did.

I think the issue relates to the access method of using network redirectors but dont know enough to resolve this myself. Mapped drives on other WDmycloud devices is fine, only the mycloudhome device using the network redirector has the issue. It seems to be related to Windows 10 as my other devices like the phone and browser are having good response times. I have reinstalling WDDisvovery over 10 times, deleted temp files, and trying every config I can think of on the windows device and the router, I haven’t got anywhere. I haven’t tried changing the MTU size as I don’t know how it will affect my SKY box, and I have a sky router. My last attempt might be to upgrade to windows 11 to see if that makes a difference. Any advice from anyone who has fixed this will be welcomed.

In order to resolve this problem I removed the WD software entirely and just map directly to the network device. I use Windows 11 Pro.

I use one of the Acronis backup tools (can’t remember which flavour precisely) and map to it as NAS.

I drag/drop files to the Public directories without the need of the WD software.

I access my files in the cloud via OneDrive or iDrive, I’m overly covered :slight_smile:

Check process explorer or task manager during these minutes and check kdd, WD Discovery and wdsync.exe for high cpu usage will tell you if WD Discovery (WDD) is actually freezing Windows 10. The whole point of using WDD is to have desktop direct access to the kddfs (‘private user space’ but shareable remotely over the internet). A slow remote connection will slow down the file explorer process while the remote files are accessed.

If one is just using the limited My Cloud Home SMB LAN supported drive, clearly one does not need WDD and can map the SMB directly in file explorer address bar with \\Mycloud-XXXXXX where the last 6 chars are those of the serial number on the bottom of the MCH.

WDD allocates a 2 GB cache disk space on the Windows partition and any slow down of the Windows drive, a slow HDD instead of SSD for example, or a lack of disk space on the Windows drive will also appear to freeze file explorer. However this is usually not the cause of any slow down. The primary cause is the slow speed of the remote connection and it is usually a mistake to point a file explorer to a remotely mounted My Cloud Home with many files or many large files as WDD will try to read a lot of that into the cache and will delay the file explorer process (2 GB cache will take 30 seconds to a few minutes to fill with a slow remote upload typical of a home internet).

Hi Thanks for replying.

I have two networked devices, my old wdmycloud and the newer MycloudHome, the former works fine the latter hangs. The MyCloudHome is not publishing shares unlike the wdmycloud which is why I use WDDiscovery for the MyCloudHome device.

Both are on my local wired network. I have already checked the processor and it is fine, it is not high on the CPU, Memory nor anything else. The processes are running however WD Support tells me it a 64bit product yet the processes running are 32bit. Explorer is not using high cpu either. I have an SSD Device HP-Spectre360 i7 16GB RAM - to be honest when I used my old surface pro with my 8GB RAM it was faster. My router is the new sky router 1gb, my switch 1gb and my cable cat6e. I use WDDiscovery to open the folder and its sole purpose in my life is to backup my photos from my local disk to my networked drive. When I first got it, it was much faster, and I had a slower machine, less ram, and a slower network. It slowed down since buying a faster machine, and faster router. I have checked my router logs and nothing reported, ping doesn’t drop packets, and no signs of latency and cpu on my machine is not maxed out.

Your suggestion about the cache is interesting though , do you know where the cache is stored on the C partition, could it be windows defender putting restrictions on the device so perhaps excluding the cache from defender might be an option. Just a thought. Thanks.

The old My Cloud did not use the ‘private user space’ kddfs as far as I know. For the MCH, only files on the private space kddfs can be accessed or shared over the internet. If internet access to files on the MCH is not required, the local MCH SMB share is a reasonable place to store them and WD Discovery is probably not needed once the local MCH SMB share can be mapped.

The WDD cache is located here
I have never seen anti-virus blocking this but it doesn’t hurt to exclude the folder to check.


I have managed to enter MCH by IP address in the Explorer Address Bar.
Found two Shares - Public and TimeMachineBackup. Both empty.

A have over 50% of the disk data on it transferred via WD Discowery mapped drive in Windows 10.
Where is all that stuff?

Is there any way to use/transfer the existing data to the Public folder.
I cannot use WD Discovery because it freezes the system and does not copy anything practically.

Thank you in advance for any helpful solution.