Success recover my MyCloud 3TB with fast blue blinking light after update firmware!

Yes, I solved it.
Here’s the whole story

1 Like

THANK YOU for posting these instructions!!! I used them to recover our MyCloud 4TB NAS. On or around Tuesday, 10/8/2019, our MyCloud NAS crapped out with the fast blinking blue light issue. I did tons of research and stumbled upon this thread. I have no clue why our MyCloud didn’t encounter any firmware update issues, until now. In any event, I managed to recover the drive and without any settings or data loss. :slight_smile:

For those using Linux to recover the drive, “nmap” can be used to scan for the drives IP address, as needed.

I do have a question: now that we have this recovery USB drive built, is it safe to use again, as needed? I presume we could skip the steps to move image files around and maybe just boot from the USB drive and see if that takes us directly to the point of uploading new firmware.

Thanks again!

Peace…

Hey I’ve successfully completed all the steps but I can’t get the firmware to update. When I click Apply on the recovery screen, the circle just goes round and I don’t get the percentage complete updates. Why is that?

I think it should be safe to use the usb again if necessary

Do you mean your myCloud has not response after flashed the firmware? Is any change on the light?

Is this only for Linux? I am using a mac running OS Catalina. Is there an equivalent process for mac?

My daughters 4TB MyCloud just stopped working about 6 months ago - inaccessible over the network and flashing blue light that went on for weeks. I just completed the instructions at the beginning of this post and am delighted that it worked flawlessly. The instructions are a lot simpler than some others out there on the web (and on this forum).

Hi the recovery file is no longer available. could you upload again? Thanks

Original instructions and files is here: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/

Hello Fox.exe As above, I was able to recover my Gen 2 mycloud using the instructions in this post. Is the procedure exactly the same (and the same recovery file) for the Gen 1 device, except for the 4.xx.xx firmware file?

There are directions both in English and Russian located at this link for how to unbrick a first gen single bay My Cloud.

https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/

The files one generally uses for the gen1 unbrick can be found at this link:

https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/

Thanks. Yes, I studied the files on this site and, frankly, can’t make head-nor-tail of them. The “English” instructions are, aside from the actual code, in Russian and the files in the Gen 1 folders are so different from those in the Gen 2 description that I can;t figure out how to use them.

The English directions are in English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt

Generally what one does is attach the hard drive to be unbricked to a computer running Linux. From there one issues, using the Linux Terminal, the various commands. On the Linux PC one would download and extract either the original_v03.04.01-230.tar.gz file or the original_v04.01.02-417.tar.gz file and push them as directed to the various partitions the directions indicate.

One can use a Linux boot disc/flash drive to boot their PC into Linux. Ubuntu is one such popular Linux distro.

Thanks Bennor. I read through everything in this website previously. Unfortunately, it is mostly Greek to me! I can usually follow instructions but I’m not a programmer or network whiz and can’t follow this once it gets into the ubuntu/debian/unix universe. Luckily, my 1st gen (040.xx.xxx) MyCloud hasn’t crapped out on me yet so I’ll keep my fingers crossed and hope it stays this way.

Hello, the link to download the file usbrecovery.tar.gz doesnt work anymore. Is is possible to provide another link? My MyCloud device did not react well to a loss of power and is now displaying a yellow light and not working anymore… Thank you for your help.

Hey @Fox_exe, really awesome stuff you’re doing and all. I was just wondering if you have any insights on the following. I followed all the steps to the letter, and now I am stuck on the safe mode page with no version number, and selecting the right firmware does nothing as well. I tried using the alternate method via telnet and all, and it does not seem to work or boot for me too, still stuck on the same. Thanks!

Hello
I’m trying to download the files. However I can’t access the recovery file. Is anyone able to share this please?

For anyone who need to fix the problem, let me share my procedure below to you and hope this help.

  1. Download these files:
    The product support site only gives you the latest (but faulty FW). Don’t pick this. Pick the FW from:

WD firmware (Version 2.31.163). Store it in your laptop.

Recovery (WD Recovery + My miniOS)

  1. Use any USB Flash drive, format it to FAT32 (Important!)

For me is it the same. Could you already find a soluton? Could it be, that the uImage uRamdisk datas for the safe/recovery modus from @Fox_exe are not correct working for every My Cloud Gen2 Devices? Is there any possibility to upload and install the firmeware bin data via USB Stick?

I managed to get it back up and working with quite a bit of elbow grease, and the help of my raspberry pi with a 3.5" HDD adapter. It’ll involve you taking apart the WD MyCloud, and in my case, I had to reformat it too.

You can check out the thread I followed here, WD MyCloud Stuck in safe Mode - #20 by ronaldyeojz. I had to google translate some of the parts but do look out for the commands portion as google translate will mess those up.

I hope this helps! Good luck!