Subtitles not showing

Hello everyone,

I recently bought a WD Elements Play multimedia drive but I can’t seem to able to add subtitles to my videos.
I created a folder where i put my video and added my .srt file using the same name as the video but it didnt work, so I saved the file in ANSI version (I saw this suggestion on some forum) but still didn’t work. 

The subtitles don’t play automatically and even I i press “option” with my remote and I go to “subtitles” menu, it says no subtitles.
I checked audio and subtitles language and they are both on “english” language as they should be. I tried to rename the subtitles file in .sub but still not working.

I tried the sub with a .mkv file but then I tried the same sub with a MPEG4 file still no results.

I also checked the installed firmware and it is the last one.

Can anyone help me?

many thanks

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Have same problem, mostly it working like intended, wd elements play corectly see any srt file which belongs to one movie but in some rare cases, it will not see any type of subtitle in folder where is movie located. Tried to recode subtitle in few diferent types like srt, sub or so, nothing nothing did not help, renaming whole movie file and subtitle file , even deleting and copy them again to media player . Deleted them both movie and sub. disconeted media player from computer , powered player again, than off , connected to computer again , copied movie and subtitle back to media player but no help, dont have any more idea what to do and what causing this.