Subtitle timing mystics


#1

I’ve been converting around 40 DVD’s now with this workflow:

  1. Copy DVD to PC with DVDFab

  2. Convert to MKV with Handbrake, including the required audio tracks. No subs included

  3. Extract subs from DVD copy with VSRip

  4. Processing subs with BDSup2Sub, adding a 520ms delay.

  5. Copy MKV, SUB and IDX (and JPG) file to the WD LIVE local harddisk

This has resulted in movies, where the subtitle timing is indistinguishable from the original DVD (in a DVD player). I have been wondering why this delay is needed, but I can live with that.

Among the DVDs converted are 2 DVDs with around 24 episodes on each from same TV series.

The third DVD from this series differ, though … now a subtitle delay of 1240ms is needed instead (i.e. additional 720ms). All episodes. Why is this? What is it, that suddenly is different in the DVD material, causing this “jitter” of subtitles?

Cocovanna


#2

Coco,

    I’m not sure.   I’ve ripped 300+ DVDs using HandBrake and leaving the subs As-Is (in other words, using HandBrake to rip the Subs and store the VobSub tracks in the MKV.)

    I don’t have an issue with Subtitle “Delay.”   A Half-Second is really not that big of a problem.   Different Studios will Lead or Lag the presentation of subtitles with audio anyway, sometimes by as much as a second.

   Are you sure you don’t have the WD set to display the subtitles faster or slower?   (If you hit the LEFT or RIGHT navigation arrow during Playback, you’ll see a Delay indication witch goes, I think, +/- 2000ms. )  If you have it set there, you shouldn’t need to be messing with re-syncing subs manually…

Just a thought.


#3

I’m not sure whether the “delay” is caused by keeping the subtitles as external files (to avoid the transparency bug). My problem is the subs are early, and it is annoying if the (constantly) appears before there is talking … a positive delay wouldn’t bother me as much.

Yeah, I’m sure the delay is set to zero in WD (I use this adjustment to find the required delay for the movie).

It is pretty simple and very fast (even for 24 titles, with a command file) to readjust the subs when I know the required amount, so I prefer that instead of “tuning” when watching movies.

Edit: My guess is, that it is something in the VSRip step that gets the timing wrong, just can’t figure out why …

Cocovanna


#4

What about using Handbrake to get the subs / put them in the MKV, as Tony does in his workflow?

That’s what I normally do too and rarely have any issues with subs.  :)


#5

Hi Pixel,

I started that way, but some of my subtitles ended up transparent due to a bug in the Live … therefore I work around by keeping them external (someone said the bug was fixed for external subs, and it seems true).

Anyway, I think I’ve found the explanation … My log file from VSRip is like this:

Indexing...
Counting timestamps from 0ms (v02c01)
Indexing mode: File
.chunk file loaded
v01 c01 lba00000000, total=560ms, off=560ms, corr=0ms, discont.:1
False discontinuity detected, correcting time by -560ms
v02 c01 lba00000007, total=0ms, off=0ms, corr=-560ms, discont.:1
v03 c01 lba00000020, total=960ms, off=960ms, corr=-560ms, discont.:1
False discontinuity detected, correcting time by -960ms
v04 c01 lba00000033, total=1520ms, off=1520ms, corr=-1520ms, discont.:1
v05 c01 lba00000046, total=2475320ms, off=2475320ms, corr=-1520ms, discont.:1
v06 c01 lba00000225, total=2080ms, off=2080ms, corr=-1520ms, discont.:1
v06 c02 lba00011163, total=35720ms, off=2080ms, corr=-1520ms, discont.:0
v06 c03 lba00063538, total=197360ms, off=2080ms, corr=-1520ms, discont.:0
v06 c04 lba00080045, total=237680ms, off=2080ms, corr=-1520ms, discont.:0
v06 c05 lba00242444, total=748360ms, off=2080ms, corr=-1520ms, discont.:0
v06 c06 lba00357365, total=1134960ms, off=2080ms, corr=-1520ms, discont.:0
v06 c07 lba00440586, total=1370400ms, off=2080ms, corr=-1520ms, discont.:0
v06 c08 lba00621633, total=1940000ms, off=2080ms, corr=-1520ms, discont.:0
v06 c09 lba00709090, total=2242240ms, off=2080ms, corr=-1520ms, discont.:0
Indexing finished
Saving files...
Subtitles saved
Done!

– and this corresponds with the fact, that I feel comfortable with a 1240ms correction – I probably cannot notice the lasr 280 ms … at least I now can see the value during processing :slight_smile:

Cocovanna


#6

Some TV series come with copy protections that are tough to handle. To rip them properly with DVDfab you need to rip each ep separately (use a batch) otherwise there might be certain delays (sometimes audio, sometimes subs or both). Maybe this is the case with your files too.


#7

I don’t think, this is the issue here … they work flawlessly otherwise, and the 500ms “early” subs are present in all my hitherto converted movies (BD too) – and these all show “0” in the VSRip log. The only disks that differ are the ones (one set), that gives a correction (~1600ms) in the log as shown above (and requires ~1200ms correction). Still a little weird.

Cocovanna


#8

I should add, that the ripped images plays perfectly directly both at the pc and at the Live (with no timing issues), so it can’t be a rip problem.

Tony, how come you have not run into the transparent title issue? It is present at around half of my DVDs …

Cocovanna


#9

Couldn’t tell ya…   I can’t swear I haven’t since I don’t enable the subtitles all the time.

But none of the ones I’ve LOOKED at have had it.


#10

The problem seems to be VSRip (bug, probably). It skews the timing of reasons I don’t know.

I have reverted to let Handbrake/tMuxer extract the subs and include them in the MKV file. But as this ALWAYS seems to give a transparent color, also for Blu-rays (though not so obvious if it is one of the shadows or the edge), I then extract the subs (and remove them) from the MKV file. This gives much better results.

Cocovanna