Subtitle problem from NAS


#1

Subtitles cannot be played from NAS! 

The subtitle functionality works as it should from USB drives and from PC based media servers.  It just doesn’t work from NAS, and this is a serious problem for me as I only have a NAS at my place.  I am hearing impaired and I am just not able to understand what is going on without subtitles.

It is not related to the type of NAS, as I have a DLNA/UPNP compliant NAS from Lacie, we also tried with other types and brands of NAS.  It always plays perfectly, but it doesn’t show subtitles.  When trying to go to options to select subtitles, it says there is “no subtitle”.  There is apparently more people with the same problem after googling a little bit.

Anyone else here having a problem with this?


#2

Hello from Greece

I have  the same subtitle problem with the NAS connection . I tried with 2 NAS systems (Thecus & Synology) but w/o any result.

I am supposing that a new firmware release must be the solution.

Regards


#3

lukas from Czech

ive the same problem, i have ReadyNAS x WDTV live and i cant play movie with subtitles - any help?


#4

Hi there!

Are you using the “Media Servers” (DLNA) option on your WD TV?

If so, that’s the problem right there. It doesn’t support external subtitles (dunno about internal, like on mkv).

You have to use network shares.


#5

can u show me - how can i set it? step by step?

thanks


#6

If your NAS supports windows shares (SMB or CIFS), you need to set it up so that the WD Live can access it through “Network Shares”.


#7

Hi,

I have the same issue. Have linked Synology 108j with N-Draft WiFi d-link stick and it works fluently even with Blue Ray copies, but without the subtitles. :cry:  No matter if .sub or .srt…

Is there a solution from WD? Or can somebody help me create the Network drive access from the NAS. PLEASE! When i choose the Network drive it brings a message that it is not accessible!?!?

Can somebody help. The NAS supports CIFS, but I don’t know how to open it free.

THANKS

K


#8

Hi All: Just register to vent my frustation with the WDtv live.

Maybe the no sub over NAS is not a big problem for english speaking costumers, but for my wife and parents in law is it a big issue. The fact that I can watch the movie with subs in my PC and not in my TV though the WDtv live as I was promised really makes me mad.

Yes, I know it works if I use networks shares, but, that’s again a problem. Network share only works when it wants. Sometimes it connects to my PC and sometimes not. And is that unreability that drives me crazy.

I really hope they fix this issues as soon as possible.

Cheers.
p.


#9

I’m English speaking and subtitles are important to me. I watch a lot of foreign films. I think you loose some validity when you start off with a pretty racist comment.

You don’t give a lot of details so its hard to say exactly what your problem is. I have no issues connecting to my NAS or to my linux box using smb. I think you should check your router or whatever dongle you’re using for wireless or check your connections if hard wired.


#10

Saying that for english speaking user subtitles are not that big of problem does not sound racist to me when most of the movies in the world are english-spoken.

My problem is the same one that a lot of users have. No subs over NAS and problems with the WDtvlive connecting with my W7 PC.


#11

> * * *

warchild wrote:

 I think you loose some validity when you start off with a pretty racist comment.

 


 

If you consider the comment to be racist then I believe you are widely over reacting.

 


#12

I have also had problems with this. If I access my NAS (Iomega Ix2) as a Media Server, then I do not get any subtitles to work (.SRT or .SUB).

If I access the NAS as a Network Share, then it seems that the WD TV Live box is VERY sensitive to the filenames. If the filenames contains ANY special characters like ( ) [] or additional dots (.) or if the filename is too long, it seems not to be able to display the thumbnail and neither use the subtitle (.SRT or .SUB).

I hope WD will improve this soon.


#13

I have several files with additional dots that work just fine so I assume it’s rather your NAS being sensitive to filenames.