Subtitle issue - WD Live not recognizing subtitles - due to new update?

Hello WD Lovers!

Recently, I’ve noticed my WD Live box is having issues recognizing subtitles.

It has issues recognizing SRT, SUB and IDX files.

I’ve only come across this over the last month (around the time when the new update came out).

I’ve tried back-rolling the update but to no effect.

Movies with subtitles that functioned properly last month, no longer recognize subtitles.

Note - I’m using network share on WD box (WD Live hard disk connected through my router).

I have the latest version of WD box (bought a year ago - the one with the wifi built in).

Could this issue be caused by the most recent software update?:confounded:

Does anyone from WD (or WD community) know if there is a new update coming on the horizon to fix this issue?

Thanks one and all for your help!  :smiley:


Salty Swift

DLNA usually does only external SRT so if you say you’re using network shares, the subs should show up as they still do for me on 1.06.43. So do you use external or internal?


I’m using an external WD live network drive hooked up to my router.

WD is hooked up via wifi through my network.

I hope this helps.

Thanks again for your help!

Salty Swift

Is the sub internal (muxed into an mkv) or external?

Subs are external.

In all cases where they’re not working (be they IDX, SRT or SUB), they are separate files (in the same directory of course as the MKV file).

Well, if they are named identically (except for the extension) the WD should play them also over Wifi shares. All these formats work for me on LAN shares just fine.

Yes - the subtitles are named identical to the MKV or MP4 file.  Absolutely no variations.  None.

I know that WD should play them but as of a few weeks ago (time of last update) it simply refuses.

Does anyone from WD know if there were tweaks introduced in the new update that altered the subtitle options or extension of subtitle files that are playable?

Ok, a couple of things.

First, this thread is in the wrong forum.  The forum for the “Built-in WiFi” WDTV is here:


Confirm that you’re actually accessing via network share, not media server method.

How do I actually check that I’m using network shares?

I’m pressing files on the main menu.

The WD already has a link to my WD Live HD (connected wifi through my router).

Is there a way for me to check that I am actually using network shares?

Or should I do device reset, go back to factory settings and set up everything from scratch?


The RED button selects the file source.

You mean the OK button?

What I meant to ask is this.  If I select files from main menu, does this mean I’m using network share option for the WD HD which is hooked up via wifi to the WD?

Or must I select another menu?

I just find it strange that subtitles would stop working suddenly last month after the software update.

No, I mean the RED BUTTON on the remote.

There’s the four colored buttons on the remote… the RED button (unless you changed it in the UI) selects the content source.

Wow!  I can’t believe it!  I had no idea what those colour buttons were for!  It worked!

I don’t think there was even a user’s guide included with my WD Live…go figure!

Thanks one and all for your help!!!

You can always download the manual from here.