Stuttering while playing files with high bit rates over local USB


#1

Hallo everyone,

I’ve got trouble playing video files with high bit rates. The files are located on a USB Harddisk, attached to the WD TV Live Player. After a few seconds audio and video get’s massive drop outs.

The problem occures only while the WDTV scan’s the USB drive for media. After the scan has finished, everything works fine. Is there a way to prevent the WDTV from scanning the drive(s)? By the way, The “Media library” under System Setting has already been disabled.

My Drive contain’s a lot of media, so if i wan’t to play a high resolution movie, I have to wait at least half an hour.

Best regards,

Schlaudia


#2

Welcome aboard!

Hmmm.    You’ve already done what I first thought (disable Media Library)

If there’s an EXISTING media library already, though, I wonder if it’s checking into it?

Plug your drive into a PC and delete the hidden .wd-tv folder that’s in the root of the drive, and see if that helps.


#3

Thank you Tony,

I’ll check it this evening and report the results.

Best regards!


#4

Ok, back again,

I just removed the .wd-tv folder from the disk - without an effect. The WDTV simply created a new one and scanned the drive again. Any other suggestions?

Kind regards,

schlaudia


#5

If it created a new one, then the Media Library function must be ENABLED.   

Hmmm.   I wonder if it’s ignoring that setting??  (I don’t use USB storage, so this isn’t something I can quickly test myself… :frowning: (


#6

You say that your drive contains a lot of media. Is it possible that the drive is:

  1. Very fragmented, or

  2. Nearly full

Either situation could cause performance problems. You could probably tell by listening to how much disk activity is occuring on the drive during playback or when the media library is being rebuilt.


#7

@Tony

it makes me wonder, too. I checked it several times in the settings menu: The media library is definitely set to off. I don’t know why the box is ignoring that.

@parnott

I knew the points you mentioned and I have already defragmented the drive. It’s size is 2 TB and there is still at least 50% of the capacity available.

It is interesting, that when the box has finished scanning the drive, there are no more performance problems. The best solution for me would be the possibility to set the scanning to off. But I don’t know how to do this!


#8

Something to try, it may help you never know.

Unplug the external drive

On the WDTV:

reset to factory defaults via the side paperclip button

reset to factory defaults via the internal menu

unplug the WDTV from power for some minutes (not seconds)

Do not use until you have done all 3

Turn off media library via the internal menu.

Delete the hidden wd_tv folder on your drive.

Plug the drive back into the WDTV and turn on.

Is it still the same?


#9

Just completed all 3 steps, followed by disabling the media library. Still the same behaviour! It’s anoying, the **bleep** box still rebuilds it’s media library in the .wd_tv folder. I don’t know what to do next. It seems to me  that the media library setting is ignored :-0


#10

Do you have thumbs or other images in your library?

If so – delete them and see if it makes a difference.  I don’t know what else it would possibly be scanning for.


#11

I think we’re seeing a bug here.  I’m going to need to try it with my LIVE and PLUS and see if I can reproduce the issue.   If Media Library is turned OFF, there’s no reason for it to rebuild the database.  

It’s apparently fairly process intensive to do that step, hence the issue until the DB is built…  


#12

Ok, media Library OFF does SOMETHING because the .wd-tv folder is recreated, but only one file is put in it, an “edid” file.

With media Library ON, three files are put in it.

Not sure what the difference in performance should be though, but it’s pretty obvious that it’s less-than-desirable…


#13

TonyPh12345 wrote:

If it created a new one, then the Media Library function must be ENABLED.   

 

Hmmm.   I wonder if it’s ignoring that setting??  (I don’t use USB storage, so this isn’t something I can quickly test myself… :frowning: (

It creates the folder for the thumbs cache (local drives).

Cocovanna


#14

Which is why I suggested deleting all thumbs (all extraneous files, that is).  Perhaps that’s what’s taking so long.


#15

Unfortunately the folder is created even if there is only one file on the disc. As has been said the wd_tv folder now holds thumbs for all the photos and embedded cover photos in mp3’s and movies. I assume that if you have a large amount of files it will still scan through them to find images even if if none are present.


#16

But I don’t see this behavior, Rich, even on my large locally attached drive (it has TONS of files but because they are all TV shows none of them have thumbs).

That’s the reason I suggested the OP delete any thumbs on his drive in case that’s what it’s doing (cataloging them).  He has never said one way or the other, though.


#17

I does not start making thum caches before you enter a directory with the Live … and then in only makes thumbs for that directory (not subfolders). I even think, it only makes thumbs for the ikons you see (i.e. 12 files) at a time

Cocovanna


#18

My problem has been solved, i brought the device back to my dealer…


#19

Did you exchange it or just return it?