Stupidly slow My Book Live Duo 2TB

So I have spent a while reading the various threads around performance and slowness but none seem to address the sort of issue that I am seeing.

If I simply want to transfer a 6Mb picture from my PC to the MBL it takes about 5 mins. The claimed transfer rate is 28.4kb (no that is not a typo) This device seems to be ridiculously slow!!!

This is how I am setup and what I have already done:

1 Gbps NIC

1 Gbps Switch (even if I were using a 10/100 switch I would expect better performance than 28.4Kb!)


The PC and Duo are both connected to the switch with very short CAT5 cables. I have replaced both cables and the switch and seen no difference. I have tried turning off the firewalls and all anti-virus and seen no difference. I have tried changing the storage mode to see if that makes a difference and no it doesn’t. I have all the services turned off iTunes etc. I am using the correct Network protocols etc.

I have 200Gb of photos to back up and that will take weeks at 28.4Kb any ideas where to go next?

That may be related to a WebDAV issue.

Try browsing the WebDAV FAQ to see if that applies.

already checked that one I am connected using Microsoft Windows Network

any other ideas from anyone?

Do you have any friends that have laptops that can come over and plug into your network and try on a different PC?  – or you might consider taking your MBL to a friend’s house and setting it up on their network?

I cannot imagine what would cause performance as pathetic as what you’re seeing.

Generally when people say it’s slow, they’re getting only 5-10 megabytes per second.   You’re getting 1/100th of that.

I, however, get 10x that (50-60 megabytes per second.)

The above is more or less to try to narrow down where the issue might be.

Here’s another idea:   Test a “local copy.”

Log in via SSH to the MBL.

Locate a fairly large file on the MBL  (10 megabytes or large) in the SHARES folder:

Make a copy of the file via command line.

For example, I have a video file in /shares/Public folder.  I’d do the following commands:

cd /shares/Public

time cp Video.mkv Video2.mkv

When it’s complete, it’ll output something like this:

real 0m0.000s
user 0m0.000s
sys 0m0.000s

 Tell us what the “real” value is, and the size of the file you copied (in bytes.)

If THIS test is really bad, then you might have a bad HD inside the MBL, and the system should be replaced.

apologies for not coming back quicker life got in the way!!

This is the output that I see:

real 0m0.937s the file size was 8029184 bytes

I guess that is pretty much ok?

also just checked with my laptop and speed is fine so must be something **bleep**ty in my network :frowning: Must be either the cable to the PC or the PC/NIC

really stumped by this!

Transfering a file from my laptop (Wireless) to the MBL is “relatively” quick 4.5MB/second

Transfering a file from my PC (wired) to the MBL is slow 24kb/second

They both go via the same switch to the MBL. 

Checked all cables. Turned off Anti-virus etc and still the same performance…what is going on?

Those are two different PCs?  Or the same PC?

If they’re different, try shutting off the wireless on your laptop and hard-wiring it and see if there’s any difference.

yes two different PCs

I shut the wireless off on the laptop and connected via a lan cable and got 20Mb/second

clearly a problem with my main PC the question is just what?

Just as a test for comparison, enable FTP on the MBLD and try some transfers by that route. Filezilla is free, and easy to set up and use. I have gotten the absolute best rates for large transfers with FTP

Ok so I can connect via FTP but I am still getting the same slow speeds 24kb/second!!!

What else do I need to check seems to be a problem with my PC?

If your PC has both wireless and wired connections, you might want to check out this article:

Sometimes the priority of the interfaces can get swapped.

I am only using a wired connection on my PC

buzzpearce wrote:

Ok so I can connect via FTP but I am still getting the same slow speeds 24kb/second!!!

What else do I need to check seems to be a problem with my PC?

Well that’s disappointing.

If this machine connects to the Internet via broadband, what kind of download speeds do you get for a large file from a decent server? (I’m thinking something like a display driver, Windows Service Pack, etc. I mention something large from MS because I have usually gotten good download speeds from them.) If you are not getting worse-than-dialup speeds from broadband, it would suggest that the NIC is not the issue, either.

Yeah I looked at that too. I have a 60Mb connection and get very fast downloads from the Internet so presume my NIC is ok

Ok I think I have solved this!

In light of all the above I had a look at the network protocols being used on the NIC which included two I didn’t recognise:

RRNetCap Driver 

AvFw Packet Filter Driver

A quick Google brought up this article in relation to the later  and this immediately caught my eye!

Two unwanted error situations have been noticed, when using the Avira FireWall and network cards of the company Qualcomm Atheros:

  1. The speed within the network decreases massively in certain situations (e.g. during printing of network printers or data transfer to a network drive ).

So I disabled and then uninstalled this and restarted the PC. Initially there was no change. However, I then decided to disable the RRNetCap Driver and everything sprung to life!! Even when I then re-enabled that driver things are still good and I am now seeing transfer speeds of 32Mb/second :smileyvery-happy:

So hopefully all solved now but may well be useful to someone else using the same NIC and Anti-Virus.

1 Like

Great Work! Bravo and Congratulations! That sure is a narrow combination of factors to track down.