Stuck in Safe Mode - endless spinning on firmware upload on EX2 Ultra

After some experiments I stuck with my EX2 Ultra in Safe Mode. When I open the device ip in browser, I see - I’m able to access it’s ip, and I can see traditional Safe Mode window see attached screenshot :

When I try to upload any firmware (I’ve tried both latest OS3 and OS5 images) I see progress spinner, but it just stays there until I refresh the page, there are no progress numbers or anything. I’ve tried this with different browsers, but no luck.

I’ve also tried pressing reset on the back panel - both 4 secs and 40 seconds with disconnecting power, but the problem persists.

I cannot ssh there, looks like port 22 is disabled.

Any ideas what can I do to finally restore firmware? I’ve already saved my data from the HDD, so I have not concerns about formatting it.

Hi @arghtype,

Please refer to the following KB article: https://support-en.wd.com/app/answers/detail/a_id/25172

Hi,
thanks for your reply. Unfortunately, I follow this guide, but my problem happens on one of its steps - I got infinite spinning progress wheel when I try to upload any firmware