Struggling with recovery

Hi all… I’ve been working on a DX4000 to recover it for a few weeks now. I finally have time to really clamp down on it this weekend.

It’s old and was given to me. It powers on but gave a 0x0D or similar error upon receiving it a few weeks ago. I don’t know it’s past functional state before I received it… The gifter said “Here, if you can make this work, you can keep it.” It appears to have the original drives.

I downloaded EMEA_SvrRecovery_1_7_5_17.iso and I’ve been trying to recover the device. Choosing the third option “Perform a recovery” results in an eventual “storage bad”. I’ve tried recreating the USB drive via the utility that came in EMEA_SvrRecovery_1_7_5_17.iso each time but it doesn’t seem to change.

Using the second and middle option “Recreate my storage” results in what appears to be a hung load where the device’s LCD displays “INITIALIZING OK LOADING RECOVERY.” I let it sit for 10 hours with no change or activity on the USB drive’s indicator light.

In any case, there are no red indicator lights for any of the disks. They are either all blue or all off depending on the phase of operation.

I’m half tempted to pull each drive and attach it to a workstation I have and check the health of each disk. I’m not sure if that would lead me anywhere.

Any advice or suggestions this community might have for me would be outstanding! Thank you!

You will have to complete the middle step first and there will be a log file on the thumb drive that may be helpful. It would not hurt to do a diskpart clean on each drive and I suppose while you have each drive slaved or in a usb dock on a PC some health check would be a good idea.

But the main thing you need to do is acquire a MD5 hash file for the download and make sure it is a good download.

1 Like

Thanks Gramps.

Middle option fixed the storage the 3rd time around… Trying 3rd option now.

My MD5 has is: 46649c0b8acca02c6544514e5c99bd4c EMEA_SvrRecovery_1_7_5_17.iso

Which matches up with the MD5 in this thread: WD DX4000 Sentinel Recovery Disc

UPDATE: Third option worked and I’m not in the actual recovery phase where I am resetting the device to factory defaults and deleting all data (formatting drives).

My steps so far have been to:

  1. Download the recovery ISO in this thread: WD DX4000 Sentinel Recovery Disc
  2. Mount the ISO with windows 10 and run “SETUP.EXE”
  3. Create a recovery disk with a 16 GB USB thumb drive using the second/middle option of “Recreate my storage”.
  4. Plug the USB thumb drive into one of the USB ports and press and hold the reset button on the back while powering on the device and following the instructions on the recovery utility presented on my computer. (This part took 3 attempts… the first two failed/hung.)
  5. Once the storage was recreated successfully, I created a second USB thumb drive recovery using the SETUP.EXE utility’s third/last option of “Perform a recovery” and followed the same steps as the “recreate my storage” above.
  6. Once recovery was complete, I followed the steps to reset the device to factory defaults and then format the disks. (Leaving the data was an option.)

I’ll provide more updates as the process continues and update the steps taken to be complete if successful.