Streaming home video files stored on my WD MyCloud

Hi, I’m really new and not and not very good with all this computer stuff. I have installed my new WD MyCloud and have downloaded all my videos that I have taken from my iPhone & ipad. They look fine and play fine on my computer but when I try and play them on any of my TV’s from Mycloud there is a number of issues. 1. lots of the videos are either upside down or on their side, 2. file not supported message comes up although all the videos were made on either the same ipad or iPhone so don’t understand why some are supported and others are not. 3. On all the Samsung Tv’s the video keeps stopping and the message ‘prepairing video’ keeps coming up all the way through so video keeps playing a little then stopping then playing then stopping. Please help…

They look fine and play fine on my computer but when I try and play them on any of my TV’s from Mycloud there is a number of issues. 1. lots of the videos are either upside down or on their side

The orientation of the video may depend on the orientation of your iThing when you made the recording. There may be an orientation flag embedded in the video that the replay app on the PC interprets correctly, but your TV does not.

Some questions:

i) when you play videos back from the MyCloud using your TV, what app are you using to view them with? Do you know if it is accessing a media server (it might mention UPnP or DLNA), or a network file server?
ii) how is your Samsung TV connected to your router? is it by WiFi? can you try connecting it to you router using an ethernet cable?
iii) when you play videos back from the MyCloud on your PC, what app are you using to view them with?

Regarding video files, ‘file not supported’ and MyCloud. I found that on my PC under Windows 10, I am able to find an app that can show them, and change the ‘default’ app in the control panel to that app, and I can view the video files. This has worked for .MTS and .M2TS files for me (while .MOV, .WMV and .AVI video files already viewed before the change.

However, on my Tablet (acer Iconia One 7 B1-750), I have found no resolution (yet). Yesterday I worked with ACER support, who indicated that it was not a tablet issue but a MyCloud issue. Today I worked with MyCloud support and they indicated that they only supply the file through MyCloud and have no ability to resolve the issue with being able to view the file on Tablets.

There is/are other WD Community comments regarding this issue which indicate that the ability to ‘open with’ (app) doesn’t exist on Tablets (or is is android devices?) and this would solve this issue.

I intend to go back to Acer, who indicated an alternative support source to help resolve this issue for me. If I do get one, I’ll update this comment.

On Android, use a decent video player app, such as VLC or Kodi. They’ll play just about any media format you care to throw at them.

Kodi certainly allows you to ‘Add Videos’ using a direct SMB file server connection to the MyCloud. VLC probably does the same. So you don’t need to use the MyCloud app for local network access; you’re much better off mapping the drive into your device’s file system, and accessing it just like you would the local disk, a USB disk, or an SD card. After all, you wouldn’t use a disk/card manufacturer’s app to access any of those, would you? You’d just use File Explorer, Finder, File Manager, etc.

I’d suggest you only use the MyCloud app for remote access to your MyCloud.

hi there, when I view the videos on the TV I am streaming them to the TV from the WD MyCloud storage device it comes up as DLNA. I’m not using an app. When I view them on my computer it is through windows media. But if I look at them on my computer in my WD My Cloud they all look fine as well.

o the computer I have is also an Acer - brand new as is my storage WD MyCloud. All me files are MOV but some work and some come up as not supported. Also don’t understand why the ones I can see are either upside down or turned to the side.

MediaInfo will help you find out what ‘container format’ and ‘CODEC format’ your videos are recorded in.

This might help you determine why some play, and some don’t.

https://mediaarea.net/en/MediaInfo/Download

I don’t need remote access. all my videos are either taken on my iPhone or my ipad. I then download them to my computer and they are saved on my hard drive. I then save them aswell on my WD MyCloud storage drive. All our TV’s have server cables in them direct none of them are wifi. It appears the problem is from the MyCloud Storage drive to the TV’s. I did download the WD photos app on my phone & iPad but it wont download my save videos or music from my storage drive. And will only download a limited number of my photos

There are a number of reports of the Samsung DLNA media viewer giving trouble, so I’m not too surprised it’s the TVs giving you trouble.

As you’re using DLNA, you will be accessing the Twonky media server on the MyCloud. You might try checking the ‘media receiver type’ for your TVs. Have a read of this thread:

all my videos are either taken on my iPhone or my ipad.

But for some reason, they’re not all playing. The MediaInfo suggestion was to compare one or two working videos, with one or two that aren’t, just to rule out the iThings being ‘too clever’. It might also gives some clues about resolution & orientation. Your TV might refuse to try to play a portrait aspect video, for instance, thinking it cannot show 1920 vertical lines on a 1080 line display.

I ‘bit the bullet’ and purchased a conversion program (Wondershare video conversion), which allows me to ‘convert’ the .MTS and .MT2S formats to .MP4 format (my choice of output). While the VLC media player does have its own conversion process (and it’s free), I found that it doesn’t convert well - the view was mostly garbled.

I replaced my .mts & .m2ts files with the .mp4 files and they show ok.
I also found that I needed to separate the pictures (into ‘shared pictures’) from the videos (into ‘shared videos’).

I see that the Acer Tablet seems to do a better job of showing/viewing the pictures than my computer does.

It appears that .mts & .m2ts (as well as some other) formats are not readily handled from MyCloud into computers or tablets.

I was frustrated with the same issues and found a solution that works for me. On my Acer Android device I installed an app called “AllConnect” basically I run it pick what device I want to stream to and then select Servers and select WDMyCloud it works flawlessly every time. I hope this helps other frustrated people.