Strange solution to not seeing shared network folders

I am not technical gifted enough to tell, what this is all about, but… Yesterday my WD HDTV Live no longer showed my shared folders from my pc. I’ve recently changed my D-link Dir-100 router due to a crash, but same model and it worked fine. So that had nothing to do with it, plus I could see my WD connected to my router, when I logged in to the router. I am also pretty sure I saw my WD in my Windows 7 explorer menu. So, why did it no longer work? Then I remembered having just, yesterday also, installed skype while trying to install Microsoft’s msn chat program. Msn is now being replaced by Skype, hence the reason for me installing Skype. Anyway, I remembered an earlier experience, completely the same result, where I also installed Microsoft Live Essentials that came with a Msn install. So, I then uninstalled Microsoft Live Essentials, found in the list of add/remove programs. That didn’t make a difference. Then I found Skype and uninstalled this too. Bingo. My WD now showed my shared folders again without any problems. Long story short: For some reason my WD HD TV Live can’t see my shared folders, as soon as I install Microsoft’s Live applications, Msn or even Skype. No problems using MS Security Essentials though, go figure. Anyway, just wanted to share my discovery, in case it can help others experiencing the same problem as me.


Thanks for sharing… Maybe that media player was still rediscovering the network since you changed the router.

First time I heard about problems with the MSN or Skype… 

But who knows. If that was the cause, this should be helpful

Maybe I shouldn’t have mentioned the router, since it was of no importance. There were no problems, neither with my old router, nor my new one. I think I just wanted to illustrate how I had to think to find the answer to the riddle. But since this was the 2nd time I experienced my shared folders vanish on my WD HD due to msn/live applications, I thought it might be a good idea to share this with other. Also I’m hoping that somebody might explain, how this problem occurs, which changed settings might result in this outcome.