Strange Public/Private Access and Other Issues

I recently bought a MyBook Live and have had nothing but problems with it.  Firstly I couldnt get the device to connect remotely, but figured it out after a full factory reboot.   Now i am having more issues.

I have everything set up great, and I make myself a private folder on the drive.  Ok.  I try to connect to it, and It wont accept my password.  I did some research online, and found the  “net use * /delete” trick followed by the remap.  I tried this, and it didnt work.  I tried multiple times, to no avail.  So at this point, I have two shares; PUBLIC and PRIVATE, which I can only access the public.

I though it might be a good idea to delete the private folder and try the whole thing over.  I also went into the Admin user and changed the name to my own, since I am the admin.   Something happened during this process, recreating another admin and degrading my username, and the MyBook Desktop will no longer allow my to create users, delete users, create folders, delete folders.  It gives me 33156 - You are not authorized to perform this task.   This isnt the strangest part.  When I look at the Desktop, it only shows the Public Folder.  Alternatively, when I go into www.wd2go.com my email works fine, I can log into the drive, AND I can access both public and private folders!

Picture asdf.jpg

Another picture of Dashboard showing only Public Folder. asdf2.jpg

Another picture, of my attempt to add a share. asfd3.jpg

Another photo, of my WD2GO showing access to both shares. asdf4.jpg

Anther photo, of my attempt at logging into the drive via the NETWORK tab in explorer.  Asks for PW and denies access. asdf5.jpg

I couldn’t tell, but are you logging in as an administrator or user.  You should be logging in as admin.