Strange password behavior

I’m having an issue with my passwords.  I change my admin password to a personal one.  It seems to work fine.  When I try to create a password for a guest user (let say “guest”) I end up with some extra dots (letters) that change the password on me.  If I look at my keychain on my Mac I have the password: “dGludGlu” but of course if I try to login using this password it tells me that it’s the wrong password.

I keep changing it in the user profile but I keep getting something longer than what I type.  So I’m not sure what is my password anymore.

Anybody experience the same thing?  Is there a way to fix this?

Thanks for any help.


When you use the feature Remember this password from your web browser, the saved password will autocomplete in the password text box each time you type in your Administrator Name. However, because the My Book World Edition I and II have implemented the more secure password encryption, it can cause a mismatch of the autocomplete password when logging in

check this kb article for further info

1 Like

Lawrence, I was not aware of this, I’m actully using Apple Keychain but it might be the same issue.  I will read the kb and avoid using the “remember password” feature.



PS: I have been reading your posts and found them very good, will you be able to help again on another question?

I would like to share files with friends over the internet, I have the hardest time to figure how somebody could access my sharespace from their computer.  I have a mac and they have windows machines.  I know the OS is not relevant but I wanted to mention it.

Thanks for any help somebody could provide


The way that I am familiar to access the share space is threw FTP

You can access data in a shared folder on WD ShareSpace or My Book World (white lights) from anywhere using an FTP client software program or any major web browser.

1 Like

Great thanks I will try that.



I tried with an FTP software call Cyberduck, they now have a windows version and a Mac version.  I have been using the Mac version for 3 years now to upload my website.  It worked perfect.  Thanks again.

You can find the free tool here:

No problem. Always glad to help.

Thanks again but I spoke a little too fast.  I tried at home with my Mac version of Cyberduck and it worked great.

I tried from work with the Windows version and I can’t connect, either Cyberduck for windows is buggy (I doubt that) or my internet connection is not fast eough at work (I beleive that).  My work as a very slow connection: our download speed is 2 Mbps at work when at home I’m around 38 Mbps.  I read on this forum that the internet access was very important for FTP download so I guess that might be the issue.

I will ask a friend of mine to try Cyberduck for Windows from his house.