Strange MyBook 1230 Problem

Hi everybody,

I have a problem with a WD 1230 (and an 1140) that I’ve tried everything to solve, and now I need professional help.  (I can hear chuckling out there already…read on, it gets better.  I promise.)

Since late 2012 I’ve been working on a major fan film project, “Star Trek III: Redemption,” the final film in a trilogy of fan films that I’ve written and produced.  The most recent cut of the film clocks in at just under four hours, 13 minutes, and even working from a USB3 drive, creating a full cut of the movie requires over 17 hours.

The production files for this film alone consume a whopping 2.27TB of hard drive space (and that figure increases if one includes material recycled from the first two films).  The timeline files for the most recent cuts exceed 30MB in size.

This, then, is where the mystery comes in.  Obviously, when working with a timeline file that large, load and save times are going to be protracted a bit, but for the most part load and save times have been manageable over the course of the project.  One or two minutes to open, and maybe an extra minute or two to save.  Handling of the timeline in real-time could be slow at times, particularly for shots that involved large numbers of layers, however there were no substantial issues.

About a week ago, however, something very strange happened.  I set about opening the timeline, as I’d done literally thousands of times before, only to discover that instead of minutes, it took almost half an hour to open the timeline, and that was before my video editor began relinking missing files (I’m in the process of remastering the film, and a number of shots are being re-rendered in higher resolution; when that happens, the software has to relink the file).  Altogether, it can take as much as an hour to open a timeline for editing.  Since this started, I haven’t even tried exporting a new cut, even though from what I can tell the actual handling of the timeline hasn’t been affected, nor has the time required to save.

I’ve tried a progression of solutions to try to fix the problem:

1)  Thinking some part of the video editor might’ve gotten corrupted, I removed the preference files (a solution which works with Poser).  When that had no effect, I tried removing and then reinstalling the video editor.


2)  Thinking it might be an issue with fragmentation of the production drive, I defragmented the drive.  Again, no effect.


3)  Concerned that it might be an issue with a Windows component with a dependency that resided on a bad sector (the computer was purchased new in 2007, and all of its internal components are the originals), I ran CHKDSK with surface scan enabled.  Although the scan did uncover four bad sectors on the boot drive, there was no effect.

4)  Just for good measure, I also ran CHKDSK on the production drive.  No effect.

5)  When it seemed I’d eliminated all the reasonable alternatives, I decided to completely remove Windows from the computer, and reinstall everything from the ground up, just in case some element of Windows had developed an issue.  No effect.


6)  Thinking that some update to Windows XP (the software won’t work in anything later) might be at fault, I wiped and reloaded again, this time installing my video editor before even the most critical Windows updates.  No effect.


7)  At this point, the most logical possibility seemed to be an issue with the drive itself (the WD 1140), since it seemed I’d eliminated all the possible causes on the computer.  So I moved all 2.27TB (and then some) from the existing drive onto a brand new one (the WD 1230), purchased expressly for that purpose, and then reconnected it.  No effect.

8)  The only remaining possibility that seemed plausible to me was the USB3 interface card itself, which I’d purchased separately several years after the computer and installed myself.  This didn’t seem likely, since it had functioned perfectly for years up until now, but I had to eliminate the possibility anyway, so I took what I consider a somewhat drastic step–I set up one of my i7 laptops to dual-boot between Windows 7 (which came with the computer), and Windows XP 64-bit.  If somehow the USB3 interface I’d purchased was the problem, I reasoned, then using the one built into the laptop would result in the faster load times that I was accustomed to.  But after all that–you guessed it–no effect.

As the old saying goes, “When you eliminate the impossible, whatever remains–however improbable–must be the truth.”  In this case, I’ve eliminated everything except an issue with the production files themselves–and for the life of me I can’t figure out what that might be.  Two completely separate computers (three, if you count the two versions of Windows XP on the original machine), and two completely separate drives all produce the same result.

It can’t be a file-system issue; moving the production files from one drive to the next would’ve solved that.  It can’t be an issue with the files themselves; my video editor doesn’t show any of them to be corrupt or missing, before or after changing drives.  It can’t be a hardware issue; changing computers and drives would’ve solved that.  It can’t be an issue with the operating system; reinstalling Windows XP would’ve solved that.  And it can’t be a codec issue; 95% of the video files and 100% of the audio files in use by the timeline are completely uncompressed, and those that aren’t use codecs I’ve confirmed Windows properly recognizes (and which caused no problem for several years).

The only thing I can suggest is that around the time things started going wrong with the 1140, my power was flickering regularly, and at least one of those times was while this drive was in use.  I don’t know for sure that this was the cause, but I do know that another drive–also a WD 1140–stopped working because its USB interface card (specifically the encryption control module) was damaged by the same power interruption.  It makes me wonder if maybe something like that isn’t at fault here?  Or would the process of moving my files from the 1140 to the 1230 have solved that?

You can try running some test on the drive to determine if it has any issues.

What’s the model number for the drive?

Check the link bellow for information on how to test the unit.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

I’m reasonably certain the problem isn’t with this drive, since it’s a brand-new drive.  (Data Lifeguard gives it a clean bill of health anyway.)

What I’m wondering about is if there might be an encryption issue.  The actual read/write speed in Windows doesn’t seem to have been affected, but it looks like a particular program is taking an abnormally long time to find the audio/video files it’s looking for.  Another drive on my network was damaged by a power interruption not that long ago, and the preliminary report from the recovery company seems to indicate that the encryption module was destroyed (“The drive isn’t talking to itself” in their words).  It makes me wonder if something similar might be happening here?

My theory:

If the original drive’s encryption module was also damaged, then even copying all the files off onto this new drive might not solve the speed issue if some of them weren’t decrypted properly, and now the new drive is having to decrypt them on the fly.

Is that possible?