Strange issue

Hey Noob here soz if this is in wrong place or has already been mentioned but im having a strange problem with my media player.

model # wdbaap0000nbk-aesn

So anyway my little brother borrowed it for a week or so and was using it on his soniq tv. When i went back to put it back on my tv (LG plasma) all that came up was a static screen then went blank for about 10 seconds before saying invalid format. The media player still works fine on the soniq but not my tv anymore. I tried everything the little reset button on the side also tried resotre factory settings while it was in the soniq. I tried 3 different hdmi cords and still nothing. My software is up to date. Not sure what i can do.

So i think i have narrowed it down to it being the tv itself and not the media player. I have resroted all settings on the tv and now im getting a bit further, now the wd live intro screen comes up but its all in pink then it goes straight to invalid format again. So annoying.

Have you tried hitting the RESET button on the WDTV?