Strange issue with WD 1TB My Book USB Ext Drive


#1

Hi all,

Hoping you can all help me oput with my Drive.

The drive itself sits on my desk and never moves.  It’s attached to a Dell laptop and has a mass of DJinh music on there I simply CAN NOT lose.

I turn on my laptop and off we go, sign into windows fine and at this stage my HDD starts up, prompts me to enter my WD password…all good.  Windows then starts scanning the HD for any auto start files…during this process I can see the hard drive scanning through all the files, sub directories and so on…still good.  It then prompts me what I want to do next…open the drive and so on.  I open the drive and I can see all my folders sitting there, however…when I attempt to click on the folder, explorer stops responding.

It’s also worth noting that through out this process, the LED light continues to blink from the moment it’s initiated.

Now…I experienced this before and it was because my HD was plugged into a 4 way power adapter, however on this occassion I’ve changed the plug I’m using (In a different room) and also removing the 4 way and plugging directly into the wall.  No luck!

I don’t think this is corruption of a physical disk problem, because the hard drive scans through all the directories fine when looking for an autostart file.  Some of the directories will allow be to access them, they seem to be ones with less subg directories and data in. 

It’s almost like my HD drive is struggling to initiate properly or occupied doing something else.  It’s like it’s busy!

There’s no odd noises coming from it, seems to phsically running quite smoothly.

I have tried the disk on various machines…same problem (XP and Windows7).

The problem occured when running Virtual DJ and has been like this for 4 days now.

HELP! PLEASE…I can’t my data! :frowning:


#2

Which version of virtual DJ are you running. I am running 7.0 professional

That program has a wierd tendency of changing the drive letter automaticaly. Try unistalling the VDJ and then disableing the VCD on the external hard drive when you reinstall the Virtaul DJ remeber Go to the history and find the drive letter it assigned your external once you connect the drive assign the same drive letter to the drive and make sure you keep the VCD disabled. Worked for me.