Still unreliable backing up

I have performed a factory reset on the MBL. I now have my laptop (windows7) connected via wifi to my router to which the MBL is connected. No other kit.

I have created one private share only (called private_share) and one user only (private_share_user) and only that user has read/write access to that share. Admin has no access to it.

If I open up explorer I can see the private_share but have no access to it. I click on it and I am invited to input my user credentials. I do this and now I have full access to the private_share. So far so good.

Now I open up the Smartware software on the home page. It categorizes the files on the laptop. I select the private_share on the MBL. It tells me the drive is locked. I click on the drive symbol and am invited to input my credentials. I do this - the same credentials as I used when I wanted access to access the folder in explorer. My credentials are rejected as "authentication failed’?

I give up on that and select Smartware as the folder on the MBL. This it likes. I select the backup tab, select category backup and make sure all the files types are selected. I then set the backup going and retire to bed.

I get up in the morning and note that the backup has not completed. I inspect the files that have not been backed up and note that they are all Blackberry files. These are probably security protected so I am not concerned. Crucially it tells me all my email (1.3GB) has been backed up.

I go away for a coffee, potter around on the laptop and the  return to the Smartware software to see if it has ‘thought’ anymore about those Blackberry files, although I am not expecting anything to have really changed.

But to my horror ‘things’ have changed. It now tells me that my email has not been backed up. It says (like the Blackberry files): The network name cannot be found. But earlier it told me my email ahd been backed up, now it’s telling me it hasn’t backed it up and can’t back it up.

What on earth is going on here? Why cannot I not select the private_share as the backup destination? who would want to perform a backup to a public share? Why does it continually give me conflicting messages about backing up my email?

I wish I’d never bought this.

Smartware back’s up your email every 24 hours, if you want it to back up your email w/o waiting for 24 hours, all you need to do is to extract them to your my document or to your desktop.

Thank you for your reply, but shouldn’t it have backed up all my email when I performed the first backup?

I will wait another 24hours to see what it does and report back. But please do note it says:

“The network name cannot be found”

  • which doesn’t sound at all promising.

maybe reserve an IP for your MBL so the DNS is not contstantly needing to update.  Or change your dns server to to see if that helps. 

Thanks for your reply and suggestion.

My networking skills and knowledge are very limited indeed. I think I understand your first suggestion - give the MBL a fixed IP address though I don’t know why this would solve the problem of not backing up my email, but not your second suggestion at all I’m afraid.

I’m hoping this is a screen shot of the current sitaution:

The backup share is the smartware share which is as we know is a public share. I believe the software is trying to work - if I create a new image for example and place it on the desktop it is copied over to the backup almost instantly. It’s just the email side of things - it just isn’t playing ball at all.

log into your router and either reserve an IP in the DHCP or assign a static IP.  If you made a static IP in the MBL settings without also doing so in your router, you may have issues.  I left my actual MBL settings on DHCP.

for the other part, go to your network settings on your Acer, and right-click properties of the network interface you’re using (wireless or LAN card).  Click on the TCP/IPv4 option and click preferences.  In the DNS section manually enter in the DNS server section.  You can always change it back later.

Thanks for your reply and suggestion. My TalkTalk router is actually a DSL-2780. I have gone into the menu settings and:

I noted the MybookLive had a DHCP address of - against its Mac Address - and set to automatic.

I selected this ‘line’ of information and changed the automatic setting to static.

Looking at the table again, the MyBookLive description has now gone, but against the MAC address of the MBL is the IP address of and it is confirmed as ‘static’. Can I assume the address of will be permanently set aside for that Mac address (MBL in practice). I have left the MBL itself to DCHP…

After some angst I managed to fine the network settings for my wireless connection and set the preferred DNS server to be (I left the alternate address at

Would you be able to give me a little explanation as to what I have done and how this might improve my results? Although I am not very computer networking literate I do generally like to know ‘what’s what’ and hesitate to blindly follow instructions. I am reasonably confident on PC’s but have little networking experience. 

But thanks for your help. Should I expect an improvement in the next 24 hours?

The easiest way to back up your mail is to extract them all and put them to your my document folder.

Surely the easiest way to backup my email is for MBL to do what it says on the tin:

It should be backing up my email, when it performs a category backup - like it says it will in the instructions, where it specifically says it will back up *.pst files. I would not expect to have to ‘faff around’ moving email around to ensure it gets backed up.

The idea behind all of this is to ensure I have a backup going on in the background at all times, which is particularly attractive to users, like my wife, who are NOT pc literate. That  is the iniital attraction.

Having chnaged my DHCP/static addressing etc, I am now locked out of the MBL>smartware folder.

But this is a public folder, there is no username or password (I certainly don’t have one) I can access this folder via W7 explorer (no - no update backup) but not via the smartware backup software. In effect I appear to have gone backwards.

But I may not have performed the IP address ‘stuff’ as suggested above properly, and I acccept it may be my fault at this point.

Desperately seeking a solution now. Desperate.

if you open a browser, can you still get to the dashboard by typing in http://mybooklive/UI ?  Or can you get to the dashboard by entering the IP address instead of the name?

You shouldn’t get locked out because of IP issues.  You set your router to assign a static IP to the MBL, did you also set the MBL to be a static IP at that same IP address?

There have been other issues with windows and credentials.  Do a search here for “net use”, regarding how to clear out all the connections between windows and the MBL so you make sure it’s not trying to use your windows credentials to get to the MBL.

Still grateful for your help cman548.

I can access MBL via the dashboard by either typing in your http://mybooklive/UI or putting in the browser address bar. I left the MBL IP address setting to DHCP as I thought you had sort of suggested that as a default in your posting above - seems to be ok. I am not locked out of the MBL dashboard 'system.

My problem (now) is that if I run up the Smartware software and select the MBL backup share to be the Smartware share (MBL>Smartware) it immediately asks me to input a user name and password. That has been the backup share that I have been asking the software to backup to since I performed a factory reset on the MBL quite a few days ago. I have never had to do this before, how can there be a username and password if this is a public share? (I have confirmed in the dashboard that it still is and hasn’t been inadvertantly changed).

If in the Smartware software I select the backup folder to be MBL>Public then I am not asked for either a user name or password. But of course that is not the share that I originally set up to be the destiantion of the Smartware backup utility.

I have not searched previously for ‘net use’ < i will do so now and see what I can generate.


If I type the command cmd:

net use

there is one entry for the MBL, but it is telling me it is disconnected. But I can access it on Windows Explorer and move around the folders with no difficulties?

But further update a few minutes later. Having ensured I could access and move around the MBL with explorer, I then ran net use again and it tells me the connection to the MBL is OK.

I was thinking that perhaps win 7 is first connecting to a private share on your MBL.  It would then try to use that same login for accessing any folder on the mbl, including public folders.  Sort of the reverse of this thread.

Do you have any mapping to the MBL?  You might try the net del and then try.

Can you still get to \mybooklive\public\Photos or whatever other public folders you have on the MBL?

(note, the above path would be entered in the search field, not in a web browser.)

I have to leave the house now for a few days so will  not be able to look into this further - but I will get back to you.

Very quickly trying this morning though I can access public folders (such as mybooklive>smartware) by typing into the search bar as you suggested. And I can access other public foders.

I think next week I will simply close the computer down completely, then re-start it and try and access these folders using explorer and report back on what login procedure I need to do to get access.

I will then shut it down again ans then try and see what access I can gain to the same shares but using the Smartware software - I can only sort of access these folders by selecting them as backup shares, but it may provide some useful information for you.

I think I need to precisely let you know what/if W7 login procedures are 'thrown up ’ at me at a very low level when I try and access these shares via Explorer. Do you agree that would be useful?

I am not really familiar enough with cmd line procedures to be able to use them with any effectiveness or confidence - you really would have to hold my hand at every stage.

Ok, trying to keep things simple and progress through everything in a logical order.

If I restart the laptop, open W7 explorer, open MyBookLive in the network folders, select the only private share I get this:

I click ‘Use another account’, enter the username and password for the private share and I get access to it straightaway.

This would seem to make sense to me and I would intepret it to mean:

" I am windows explorer and you have asked to have access to a private share. I need to know the username and password to give you access. I’m going to guess that the user name is maybe the username of this pc, but if it isn’t you can select to enter a different username and password."

Now, if I close down the laptop again, open up Smartware, select the backup destination to be MBL>Smartware (which is a public share with no username or password) - the Smartware software package tells me that the share is locked and that I have to enter a username and password. But there isn’t one. AND Smartware hasn’t performed any sort of backup for over a week now.

Try username: admin and password: admin if this wont work, it has something to do with the windows settings. I encounter this everytime i create a home network w/o a password and its asking me a password, the only way to solve it is to create a network with a password.Hope this help.

Nope I’m afraid admin/admin doesn’t work.

I’m not sure how to set up a home network? To get my laptop and tower PC to initially work with the MBL I just made sure that they were on the same ‘workgroup’.

Both can still see (work?) with the MBL, it is the WD Smartware software that seems to be having issues.

Is yet another factory reset required?

Close to throwing this all in the bin.

PS. Sent a support request to WD over a week or so and no reply whatsoever. Is this really a company I want to rely on I ask myself?

yellowtriumph wrote:

Nope I’m afraid admin/admin doesn’t work.


I’m not sure how to set up a home network? To get my laptop and tower PC to initially work with the MBL I just made sure that they were on the same ‘workgroup’.


Both can still see (work?) with the MBL, it is the WD Smartware software that seems to be having issues.


Is yet another factory reset required?


Close to throwing this all in the bin.



PS. Sent a support request to WD over a week or so and no reply whatsoever. Is this really a company I want to rely on I ask myself?


among other issues i had that same problem with the newest version of smartware, I rolled back to version and other than smartware hoging up my cpu from time to time all my files get backed up just fine. I wouldnt hold my breath on wd responding to your email anytime soon, when i was having trouble with smartware it wasnt untill 2 months later that i heard from them and they still wernt much help

try contacting them via phone and ask for l2 assistance for advance troubleshooting