SSH won't connect to PR4100--RESOLVED

Yes, I followed the instructions at https://support.wdc.com/knowledgebase/answer.aspx?ID=11807#ssh and I’ve set a password as required. Using “Terminal” [SSH (Automatic)] on my MBPro I use the command line:

| ssh sshd@wd-pr4100-nas.local -p22

and get the following message:

| Unable to negotiate with 192.168.111.2 port 22: no matching host key type found.
| Their offer: ssh-dss
|
| [Process completed]

Any advice appreciated. I’m hoping to use RSync to move the ~6Tb on my decade old Netgear (Infrant) NV+ ReadyNAS to my new WD PR4100 and I have no difficulty connecting to the old server and running an Rsync daemon there; getting into the PR4100 seems more challenging than anticipated. Especially since Cyberduck easily connected an SFTP instance.

Regards to the group.

[RESOLVED]

See http://askubuntu.com/questions/836048/ssh-returns-no-matching-host-key-type-found-their-offer-ssh-dss

``Preformatted text`The version of OpenSSH included in [Ubuntu] 16.04 disables ssh-dss [and apparently the current version on the PR4100]. There's a neat page with legacy information that includes this issue: http://www.openssh.com/legacy.html

In a nutshell, you should add the option -oHostKeyAlgorithms=+ssh-dss to the SSH command:

ssh -oHostKeyAlgorithms=+ssh-dss root@192.168.x.y
You can also add a host pattern in your ~/.ssh/config so you don’t have to specify the key algorithm every time:

Host nas
HostName 192.168.x.y
HostKeyAlgorithms=+ssh-dss
This has the added benefit that you don’t need to type out the IP address. Instead, ssh will recognize the host nas and know where to connect to. Of course you can use any other name in its stead.Preformatted text

Thank you to all who may have read my request for assistance. Regards to the group.

I’m glad this has been resolved. Thank you for sharing the outcome and the solution; this is likely to help other Users in need.