SSH - Root access

How do I get root access via SSH?  I have enabled it, but I can’t log in as root.  It says on the Advance Configiration tab that the password is welc0me.

Note: I can log on via admin, but admin doesn’t seem to have any special privs from command line.

Any ideas?

I’ve searched this group and see someone else has/had the exact same issue ( http://community.wdc.com/t5/WD-ShareSpace/SSH-Root-access/m-p/71300/highlight/true#M1159),,) but no solution.  This can’t possibly be limited to him and me… 

I have tried resetting to factory defaults.  No luck.

I upgraded to the latest frimware.  No luck.

I am not worried about losing any data or configs because I have it backed up, so any suggestions are welcomed.

You can mess around a lot of things if you access the My Book in SSH mode, but if you look on Google something should appear.

Alucardx23,

By saying, “You can mess around a lot of things if you access the My Book in SSH mode” I think you missed the point/problem.  I can’t login with root level permissions.  In other words, ssh as root doesn’t work and logging in as a standard user (admin) and "su - " does not work.

My assumption is that the root password had been changed in the past and will not reset when setting back to factory defaults, which I have tried a couple of times already.

username is ‘root’

password is ‘welc0me’

2 Likes

Hi, what program are you using?

I can logon to my ShareSpace as root using WinSCP

Regards

I have tried PuTTy from windows as well as ssh from linux (RHEL), however, the program doesn’t matter.  I can log in with my admin account and my personal account.  I can admin the box with both of these through the GUI, but neither account has any privs when using command line.  I need to be able to make some changes from the command line because I can’t WRITE to any nfs mounts I’ve created.  I can mount them but I only have READ access. 

You can see that I can log into the machine via ssh as admin, but I don’t have any privs…

[root@adminserver ~]# ssh root@192.168.1.5
root@192.168.1.5’s password:
Permission denied, please try again.
[root@adminserver ~]# ssh admin@192.168.1.5
admin@192.168.1.5’s password:
  _____   __  __  __          _  _   _   _  _____
 / ____| / / |  /  |        | || | | \ | |/ ____|
| (___  / /_ |   / | ______ | || |_|  | | |
 \__ | '_ | |/| ||______||__   _| . ` | |
 ____) | (_) | |  | |           | | | |  | |____
|_____/ \
__/|_|  |_|           |_| |_| \|\____|

~ $ grep root /etc/passwd
root:x:0:0:root:/root:/bin/sh
~ $ grep root /etc/group
root:x:0:
wheel:x:10:root
~ $ grep root /etcshadow
grep: /etcshadow: No such file or directory
~ $ grep root /etc/shadow
grep: /etc/shadow: Permission denied
~ $ su - root
Password:
su: incorrect password
~ $ exit
Connection to 192.168.1.5 closed.
[root@adminserver ~]#

Hello,

I just got my live book and am having similar issues. I enabled SSH, downloaded putty and WinSCP and am not able to log into either root or admin though either of those programs. I am able to connect to mylive book through the normal GUI and even connect to it through putty but whenever I try to enter a password I get ‘Access Denied.’ I have been through ever single forum about enabling ssh and root for mybook, nothing will work for me. I have even tried to connect to mybook by creating a non-root account and cannot access it this way either. The only way I can access it is through the WD GUI. What am I missing? I know what the password is…i know my admin account creds and cant access anything via putty or winscp. There has to be something that is causing this issue, especially since putty can see and connect to the mybook, it just cant verify the password. Any help would be amazing because I might take this thing back if I cant get root on it.

edit:

2012-05-25 13:46:04 Looking up host “192.168.0.196”
2012-05-25 13:46:04 Connecting to 192.168.0.196 port 22
2012-05-25 13:46:04 Server version: SSH-2.0-OpenSSH_5.1p1 Debian-5
2012-05-25 13:46:04 Using SSH protocol version 2
2012-05-25 13:46:04 We claim version: SSH-2.0-PuTTY_Release_0.62
2012-05-25 13:46:04 Doing Diffie-Hellman group exchange
2012-05-25 13:46:04 Doing Diffie-Hellman key exchange with hash SHA-256
2012-05-25 13:46:06 Host key fingerprint is:
2012-05-25 13:46:06 ssh-rsa 2048 88:c0:9b:a4:f7:4b:b6:09:f3:f2:89:8c:c0:e9:86:97
2012-05-25 13:46:06 Initialised AES-256 SDCTR client->server encryption
2012-05-25 13:46:06 Initialised HMAC-SHA1 client->server MAC algorithm
2012-05-25 13:46:06 Initialised AES-256 SDCTR server->client encryption
2012-05-25 13:46:06 Initialised HMAC-SHA1 server->client MAC algorithm
2012-05-25 13:46:51 Sent password
2012-05-25 13:46:53 Password authentication failed
2012-05-25 13:47:21 Sent password
2012-05-25 13:47:23 Password authentication failed
2012-05-25 13:47:26 Sent password
2012-05-25 13:47:29 Password authentication failed
2012-05-25 13:47:33 Sent password
2012-05-25 13:47:35 Password authentication failed
2012-05-25 13:48:04 Server unexpectedly closed network connection

1 Like