SSH permissions using rsync

SOLVED - for those that may have the same problem see the end of this post.

I am able to copy (using SSH and rsync) a directory named junkdir which contains a file named junk.txt from my home PC to a My Cloud on an internet connected router at my remote work location.

I copy the directory and file to a public folder that is visible when I login to my MyCloud account in a browser at

I can log on to the My Cloud over SSH at home though Putty and access the file and directory, view the file and delete the file and directory without issues.

However when I use the web app at to view the public folder, I see the junkdir but when I click on it I get an error ‘Internal server error … 200007’. The directory does not open, and disappears from the screen but reappears when I refresh its parent directory.

I tried using --perms as an rsnyc option but the results were the same.

To me this looks like a permissions thing but I am a bit lost at this point.

Any ideas?


PS When viewing the My Cloud at work with the desktop WD My Cloud application from home, the junkdir is not showing up at all.

Windows Explorer at work shows the junkdir directory but will not open it, error is don’t have permission to open. Directory attribute id read only and when I try to uncheck read only it says I need administrator privileges.

ANYWAY, it appears that rsync needs to adjust permissions when it copies to the My Cloud, anyone know how to make rsync do this?

I will post back if my research gives me the answer before I get help here.

SOLVED - just added --chmod=o=rwX to my rsync command.

I’m glad you were able to find a solution, and I thank you for sharing it with the WD Community.