SSH mistake .... how do I fix it ? Should've listened to the adults :)

Not really familiar with SSH but computer-confident, tried to pull off a quicker file move operation through SSH, instead of waiting very, very long to do a standard Win Explorer / Teracopy operation

In the end I cancelled it, as outlined in message linked to below.

All files still appear to be present,

BUT, under Dashboard - Shares, the “USAGE” is mistakenly reported to be several TB in each of my now 3 shares (ie. exceeding drive capacity)

Will a system restore of some kind put things back to normal, even any (seemingly minor) problems caused by me fooling around with SSH ? 

Please see my other msg here:

Any help and calming of my nerves much appreciated, thanks! :slight_smile:

The system restore will reset your NAS settings back to default, your data will be left untouched.

You can try force update the firmware once again to fix certain issues without resetting your settings. The firmware can be downloaded from this forum sticky thread. But solve your missing data in the other thread 1st…

That’s a relief! :slight_smile: Thank you!

So - just to clarify - a “system only” restore will reset EVERYTHING (except leaving actual data files intact, of course) - 

so SYSTEM ONLY RESTORE will fix anything I might have messed up using SSH, or otherwise ? 

Yes reset everything except data files, no delete no format.

On the restore part I’m not sure, depending on the mess, you could have probably solve it by rebooting, system restore or force update same firmware. But for your case I don’t see anything destructive just by a move data command within the data volume. Reorganize your data and try reboot…

Looking around now but there are a huge number of files I cannot find …

Is it possible some kind of SSH “permission” thing is making them invisible ? How could I check ?

I already did system restore, reboot, and searched around…

Some of these files should be on an external disc, some on the internal My Cloud disc, if that makes a difference … thanks :slight_smile:

No such thing as invisible data in linux. But on shell level, files/dirs with dot prefix eg. “.tmp” are meant to be hidden unless you show them all, eg. ls -a … And for sftp, turn on the options in your client to show hiddens files. But I doubt those files got renamed to dot prefix. Also those dot prefixed files are visible via win explorer unless samba was set to hide them.

I’m not sure what you did. But you didn’t mention earlier about external and internal data, if I get it correctly, you’re referring to external usb harddisk which you tried to move?

System restore won’t restore your missing data.

WinSCP - now THAT is something I can work with, rather than command-line Linux or Unix or whatever it is … :slight_smile:

Thank you very much for the help - (almost) all panic now subsided, I think it’s all sorted!

Yes, had some files on the My Cloud’s internal drive, some on an external drive connected via USB to the My Cloud. All have survived, as far as I can see, just some tidying to do.

About system restore - yes, I know it won’t restore missing data, I was just wondering if this “minimal” type of factory reset, that leaves user data intact but restores settings, permissions etc. to factory defaults - whether this will also fix anything I might have messed up using SSH … just all those SSH warnings scaring me :slight_smile:

This minimal system restore can help to certain extend, ie. messed up user/network configs. But even a full restore that wipes everything including data aka format will not help if root files got modified, ie. installing apps that replaces internal libs…

1 Like

WinSCP makes everything so much easier - WD should have made a mention of this in the manual somewhere, instead of endlessly struggling to get the My Cloud to work with the stupid Windows explorer…

One thing I can’t figure out with WinSCP - bear with me please, it’s getting really, really late / early - can I do “mirrored browsing” in the sense of having two “remote” windows at the same time, instead of one “local PC” and one “remote” window ? I realise there is probably a ridiculously easy way of doing this, but just spent thirty minutes unsuccessfully trying to figure it out … :flushed:

I’m afraid you can’t do that. But you can move files/dirs with drap & drop within the dir tree, drag+shift to copy.