SSH has stopped working!

SSH was working fine. Then the other day I upgrade my firmware to the current version “2.3.01 with MioNet” and now SSH no longer works.

glenn@glenn-laptop:/nfs$ ssh -l root
ssh: connect to host port 22: Connection refused

Yes, I have the SSH Enabled checked. I even unchecked it, saved, checked it and saved again to be sure.

I can HTTP and FTP in. Even mount the NFS. Although, now I can’t alter any of the files any more. Permission is denied on the entire drive. I can read the files just can’t update them any longer.

Since all of this happened right after the firmware upgrade, I am pretty sure that is the cause of all my troubles.

Any toughts?

ssh requires that the sshd daemon be running and this usually happens when the system is rebooted. I suggest, if you have not already done so, power down the sharespace and then power it on.   This will run some cleanup scripts, I believe, and may allow the sshd daemon to start. Sometimes if the lock and PID files aren’t removed, daemons won’t start thinking they are already running.



I had the chance to restart the unit and still no SSH even though it is connected. I get HTTP and FTP just no SSH.

I am trying a full factory reset (losing all my data) but I have it al backed up on a second unit so I can restore if this fixes the problem.

Very odd that the unit has SSH checked but keep getting connection refused.

Having it checked only means that the sharespace will startup the appropriate script and thus the sshd daemon (this is a Linux-based system). However, something is preventing that script from spawning the sshd daemon which allows incoming connections to occur. Since there is no alternate way to get into the system, you cannot troubleshoot it any further other than try and do what you are attempting now.


Drats. My mouse jittered as I was starting to reply so I accidentally accepted your answer as the solution.

It sure does take a long time to do a full reset these units. It is still saying that it is building the RAID. Guess I just need to be patient. I’ll post the results.

I did a full restore, lost all the data on the drive and still no SSH!!!

Anyone have a copy of the previous firmware so I can downgrade because this version is broken.

If you can web attach, mark ssh as off, submit the change and re-mark it as on and resubmit. This migght “unstick” it.

There is no way to down-rev firmware (that I know of).


I tried unchecking SSH, reboot, check SSH, reboot and still no go.

It seems like I may not need SSH but it still pisses me off that it stopped working. The upgrade seems to have fixed a different problem I was having that required me to use SSH to tweak. So maybe I don’t need SSH any more. Frustrating though.

But, I have not figured out how to (via the web) browse the files on the drive.  Any suggestions of where I should be looking for that?

If I can confirm that things are working properly, I will stop worrying about the SSH issue for now. Then I can upgrade and flush the other drive. I don’t want to do that until I am 100% sure this drive is working as expected.

I’m having same problem with ssh access. The service has stopped working afetr firmware upgrade. There’s no way to make it work now! Last firmware upgrade **bleep**! I hope the next upgrade could fix the problem…

my unit is still under warentee. i have just requested a replacement or refund since they have damaged its advertised functionality.

i suggest you do the same. lets see what happens.


Well I forgot to post this before… I got my drives (yep I have two of them) back from WD and they work perfectly and have the lastest firmware from what I can tell.

I have no plans on ever upgrading them again since they work.

It is sad that they had to be sent back and the official WD line is “we don’t support Linux” even though these are 100% pure Linux devices that simply expose the files to Apple and Windows. Makes no sense to say such a thing or take such a stance.

But in any case, my drives are back and 100% working and I am thrilled with the quick turn around. They weren’t gon that long. Of course I got different drives back (not the ones I shipped) but who cares.

Thanks WD for fixing them!