SSH Connection Refused in MyBookLive


anyone knows how to fix the ssh connection refused in MyBookLive. I enabled the ssh in http://localip/UI/ssh. I tried also the export and import config to edit it manually still getting a Connection refused error using PuTTY but I can connect using FTP I’ve used FileZilla and tried also in WinSCP and the connection was successful only in SSH.

MyBookLive is also fresh from factory reset.

Thank you.

I have never tried this. Letss see if another user can share some thoughts with us.

1 Like

I just tried. I get “Access denied” when I give the wrong id or password. The SSH userid is “root” by default and I don’t know of a way to change it. If you have forgotten your password you can reset it by pressing the Reset button for about 5 seconds. (That will also reset the web MBL Admin password.) The default ssh password is in your MBL doc.Mine was welcOme (or maybe welc0me).

Make sure you change the password since the default value is published. As far as I know, there is no way to change that password through the GUI. Log on with PuTTY using the default id and password and issue the “passwd” command. You will be prompted for a new password twice. If you don’t type the same new password both times your original password will not be changed.

I hope someone know or have an idea to fix it.

I tried also to disable my firewall and antivirus same result.
I tried to restart MyBookLive after enabling the ssh same result also.

I don’t know what to do, i tried everything I GUESS.

Is the “Connection refused” message a PuTTY message (appearing in the PuTTY window after it has prompted for userid and password) or a PuTTY fatal error popup? For me , on a Windows system, they mean very different things.

The PuTTY fatal “Connection refused” can happen when the connection is blocked or there is no port 22 open at the destination.

The “Connection refused” error after giving userid and password means SSH has terminated the connection. (There may be other causes, too.)

You might try using a packet sniffer like Wireshark to see how far the connect setup is getting.

it is the PuTTY fatal error when connecting.

I will try that. Thanks pokeefe!

Hmm. The fatal error when connecting doesn’t sound good. Since you eliminated the firewall possibility, and you have no trouble with FTP, it really does sound like a problem with the SSH server in your device.

Incidentally, I’ve just notices that PuTTY has a logging function that might be as good as a sniffer like Wireshark.

And in testing out the PuTTY logging function I’ve discovered that I’m getting “Access denied” when trying to access one of my two MBLs. This seems to be a password problem, but I was able to access it a day or two ago. Maybe your problem is contagious. :slight_smile:

1 Like

yup I think it was in the device, the SSH server might broken or something.
how to do the logging function pokeefe?

I don’t pretend to be a PuTTY expert. I downloaded it to test out the MBL SSH function. In other words, this is just my observation.

On the left hand side of the PuTTY there is a configuration tree. The Session category is at the top and has Logging as a subcategory. I clicked on it and it gave logging options. By default it will create a file called “putty.log” in the directory containing “putty.exe”. I tried it specifying “SSH packets and raw data”. Other logging options might have been more informative. I think most of what I saw was PuTTY and the server choosing an encryption scheme.

I’ve never tried uploading a file to this forum. I think I’ve succeeded in uploading a renamed copy of the log file. (Renamed because the forum won’t allow .log files.) The log isn’t terribly informative.

putty.txt (59.9 KB)

1 Like

I tried it just a Connection Refused on the logs

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2017.01.27 11:50:02 =~=~=~=~=~=~=~=~=~=~=~=
Event Log: Writing new session log (SSH raw data mode) to file: putty.log
Event Log: Looking up host “mybooklive”
Event Log: Connecting to port 22
Event Log: We claim version: SSH-2.0-PuTTY_Release_0.67
Event Log: Failed to connect to Network error: Connection refused
Event Log: Network error: Connection refused

though Thank you for your help @pokeefe. :smiley: