SSD Not mounting consistently - resolution on last post!

So I fell in love with the new 1TB SSD Passport and bought a 2nd one of which they both operated nicely on my MacBook dock until suddenly they didn’t.

With my first SSD I would notice that once or twice, within the last few days, the SSD would unmount itself suddenly and my Mac would pop up this window saying that The Disk was not ejected properly. I rebooted the Mac and the SSD was still not mounted and this was when I thought that the software Discovery was hindering the USB mounting, so I uninstalled Discovery and finally the SSD reappeared. After that, I didn’t really have any problems with the SSD unmounting until I bought a second SSD.

With the second SSD, it took hours to copy over 315,000 files but it did complete successfully and it had no problems until much later in the night.

While working with the computer tonight, the second SSD suddenly unmounted itself and the Mac gave me the pop up window indicating that the SSD was not ejected properly. Even pulling the cable and replugging it in, the SSD did not re-appear. Of course with all this jiggling of cables on the dock, my first SSD got unmounted too and that too I could not get remounted even with unplugging the cable and replugging the cables.

I then spent the next two hours trying to get both SSD remounted,

  1. swapping cables between the two drives thinking that the second drive had bad cables.
  2. replugging the units back in multiple times
  3. rebooting the mac with and without the SSD’s plugged in,
  4. re-install discovery in hopes that somehow the drives would be discovered.
  5. I even tried using the update firmware for Passport drives but the app told me that the drives were locked (they were not locked). They are as-is formatted as ExFat with Pargon NTFS software on my Mac.
  6. tried mounting the drives using the disk utility as I can see them (unmounted) but they just won’t mount
  7. Took the mac off the dock and plugged it in straight as USB-C, individually. Not mounting. (they did mount before this problem under USB-C).
  8. tried another USB drive to make sure that my Mac or dock isn’t USB broken and the other USB drive mounted without problems.
  9. Neither the Discovery App nor the Mac Disk Utility App would mount the SSD.

then I tried mounting under Paragon NTFS app and the wheel would spin forever (5 minutes) and suddenly one of the SSD got mounted. I also did the same for the other SSD and eventually it too got mounted.

Perhaps it is the Paragon NTFS software that is causing this problem? but I’m not sure if it is a hardware problem or software since both SSD has exhibited the sudden un-mounting of the disk without the cables being jiggled (the MacBook is sitting in its cradle).

Paragon NTFS app is the only software that would actually mount the drives. Neither Discovery nor disk Utility would mount the drives.

Currently both SSD drives are mounted and seems to be stable but this last two hours of troubleshooting has been disconcerting.

correction: one of my SSD just got Disconnected with the message popping up Disk Not ejected properly. Trying to remount the SSD under Paragon and the spinning disc is still spinning (a few minutes now). It took about 5 minutes before the SSD got remounted.

addendum: the 2nd SSD unmounted itself right in the middle of a 10GB copy and now it won’t mount at all. In fact it would disappear from the paragon list of drives when attempting to mount, then re-appear on the list a few seconds later. I also notice that the device is hot to the touch. The first SSD is only warm. I think it could be a heat problem.

The new 2nd SSD is now refusing to mount.

  1. rebooted the Mac
  2. only one SSD is now connected, the other one has been cleaned and will be returned tomorrow.
  3. spinning wheel of processing, please wait on paragon mount.

If I can get it mounted, I’ll be reformatting the device and also returning tomorrow.

This sudden unmounting isn’t a USB dock problem as I had several USB devices connected long term on the dock and this is the first time I had had sudden disconnection of the USB device.

It isn’t a power problem either as the devices would work (both connected) for hours including initial copying of 315,000 files of 600GB of files.

I do notice that once the SSD is disconnected without a proper ejection it takes a long time for my Mac to mount the SSD again. At this moment the new SSD is not mounting at all.

it is now 7AM and I have spent the whole of yesterday evening and through the night trying to figure this out. Angry? Frustrated? absolutely!!

Look it finally mounted… formatting now and returning the two SSDs today.

So although I have managed to return both units and I shouldn’t really complain but I still felt like I’ve been through the wringer when I attempted to explain the errors that I kept getting. I had to prove to the Best Buy Geek Squad that the two WD SSD did not work as stated and how do you prove that the USB drive drops off in the middle of a 10GB file copy and refuses to mount afterwards. Then when it does mount after watching the spinning wheel of processing for 5 to 10 minutes (the last mount took 30 minutes), that a USB device mounts immediately which it does when it was in the hands of the Geek Squad.

The customer service staff tells me that WD doesn’t accept open box returns when the product doesn’t seem to have anything wrong with it and my problematic SSD mounts immediately on the Geek Squad’s PC without problems.

I had been wrestling with these SSD’s for over 10 hours trying to figure out why I’m having problems and I really don’t want to be the troubleshooter.

Perhaps if I had formatted the two SSD’s to Mac Extended Journal they might not have problems but then again I prefer ExFat just so my daughter can read it on her PC someday.

Am I the only one that has trouble with these devices? where it would un-mount itself suddenly when it perhaps overheats?

I am fairly sure that if you don’t eject it properly, Mac OS or Paragon NTFS will take an extraordinary amount of time (greater than 5 minutes) to mount the SSD drive.

Anyways, the SSD have been returned and I won’t be buying any more SSD’s from WD until Costco carries them; at least if they fail within the first 90 days I won’t have to meet with a Geek Squad to explain why a product doesn’t work in my hands. Not buying anymore hard drives from Best Buy especially WD drives.

Thought I should post an update to this.

I bought a competitor SSD this morning and it has so far worked flawlessly on my Mac.

With two WD SSDs that were flawed, it had made me think that there were something wrong with my Mac.

With the competition SSD now running smoothly on my Mac, I can definitely say with assurance that

  1. my MacBook dock does deliver enough power to run a USB SSD.
  2. the USB ports are not damaged in any way that leads to an SSD unmounting by itself.
  3. the paragon software has nothing to do with recognizing or not recognizing a ExFat formatted SSD. i.e. it is not the paragon software fault.
  4. I don’t have any virus or system glitches that unmounts USB drives randomly.

I am thankful that Best Buy did accept the return of two SSDs that the customer (me) claims to be problematic.

So once again, It isn’t me, it is you (WD) that is flawed.

Instead of playing with my new Oculus Quest that just arrived by Canada Post today, I am taking time of several hours to type this up for those who might be having the same problems that I had with WD’s SSD drives. So if this helps you in any way, give me a heart :stuck_out_tongue:

Because my background is IT this problem has been bothering me all day long and I’ve been reviewing everything that had happened in my mind’s eye and came to some conclusions.

Also because my new SSD from Sam…cough cough, a competitor has been running flawlessly, all day long, I am able to isolate the problem with greater clarity knowing that my Mac is working fine. Incidentally I only have 1 2TB SSD connected instead of 2x1TB WD SSD.

So let us begin.

First of all there were actually two different problems that felt like a single problem and they are

  1. The auto un-mounting of only one of my SSDs, the other one was me pulling the plug on the SSD.
  2. The re-mounting of a corrupt or a dirty bit SSD

Number 2 will take up to 5 minutes or more via Paragon since the SSD is now considered dirty. In most cases if you remove a USB drive without ejecting it, you may need to verifiy or chkdsk the USB disk before you can mount it again.

In reviewing my memories, the first SSD I bought actually had no problems but because I had pulled out the usb plug of the first SSD when trying to fix the second SSD, I also caused the first SSD to un-mount and thus be corrupted or perhaps the better nomenclature would be the dirty bit was set and the drive needed to be verified or chkdsk.

Although I had a problem with the first SSD when I locked it with the WD Security App which caused an empty disk to be shown when I woke up my Mac, this was a different problem from the auto un-mounting. After unlocking and un-installing the security program and rebooting my Mac, I was able to see my data again with “NO MOUNTING” problems.

The auto un-mounting occurred with the second SSD of which might be three possibilities,

  1. one may be an overheating problem
  2. or optionally it could be a power problem of my USB dock when trying to run two SSD drives.
  3. the installed WD Discovery and security program.

The second SSD was hot to the touch which could have been caused by the “Get info” which had to summarize the disk usage of over 315,000 small files plus attempting to copy another 10TB into the drive from the first SSD simultaneously.

Thus the second SSD was un-mounted in the middle of the 10TB copy.

When I tried to pull the plug of the second SSD in order to re-plug it back in to bring the SSD back online, I accidentally pulled the plug on the first SSD thus accidentally un-mounting the first SSD without properly ejecting the drive.

From that point onwards, both SSDs were corrupted with Paragon taking 5 minutes to re-mount and I might even guess that Paragon is trying to do a chkdsk or perhaps verify. The first SSD took only 5 minutes to get re-mounted. The second SSD took 30 minutes.

Now my best guess for the 2nd SSD being un-cereomniously un-mounted could have been the inadequate power since I was attempting to use both SSD simultaneously.

The reason that both SSDs were able to be powered up prior is because I was only using each USB independently.

However it took a long time for the second SSD to get re-mounted and it could be of two reasons

  1. I kept interrupting the paragon app by killing the process because I thought it was doing nothing but because it contains 315,000 files it might have taken Paragon 30 minutes just to verify the integrity of the files.
  2. optionally the hardware drive was overheated and could not be mounted because it was defective

Also the fact that the SSD kept disappearing and re-appearing from the drive list, could be an indication that the SSD hardware was having problems.

At the end, after leaving alone the mount process on the Paragon app for a long time (I believe 30 minutes), the SSD did finally get mounted.

By this time I had removed the first SSD after deleting all the files on it in prep for the drive to be returned.

When it got the second SSD drive re-mounted I simply formatted it also for a return.

I think there are five possible solutions for this.

  1. don’t run two SSD on a cheap MacBook Dock
  2. if you do have two SSDs on a MacBook Dock, use each SSD by itself and not simultaneously. i.e. don’t copy from one SSD to the other.
  3. buy a new high powered MacBook Dock
  4. If a drive gets un-mounted without a proper ejection, click on mount and let the mount process run without interruptions or figure how to get the SSD verified or chkdsk in some manner.
  5. reformat to Mac OS Extended Journal or better.

I am fairly confident that as I run through my memories backwards and forwards that my summary is fairly accurate.

Once the SSD has been properly mounted and ejected the SSD auto-mounts itself the next time the Mac gets rebooted.

So it just means that if you do have a dirty bit USB Drive, just get it verified by your Mac Utility or have it mounted by Paragon since you are using ExFat.

Actually now that I am thinking about it, I did try to have my Mac Utility try to verified the ExFat format and nothing happened except that it just sat there with no action on the progress bar. So use Paragon to attempt to mount the SSD or verify it when it is ExFat formatted.

Hope this all helps and now I am finally going to set up my Oculus Quest and shoot some aliens with space pirate trainer.

Thanks for reading…