SSD Dashboard missing dll's

get missing MFPlat.dll and MF.dll error.

Hi, i have now tried all i could think of to remedy this. re-download, re-install. install with admin rights
i even tried to find the dll’s on the drive and copy them to the install folder but they are not the correct one’s so now i’m out of options. Need it for urgent firmware update.

You may be able to install the DLL using the steps in this guide:

Unfortunately none of those workarounds work. i found 3 versions of mfplat.dll and tried to just copy them into wd folder and then run the program but then it only states it’s the wrong one or broken. same if i try with the mf.dll.

You can get an older version of Dashboard by contacting support and then choose not to update the application until this dependency is resolved. Current version is 3.4 so ask for 3.3.

I found the solution! I had a facepalm moment. A clean install of windows 10 N is always missing the media pack you have to add it after the fact. I read about this but did it the wrong way i just downloaded the pack from M$ and got the error not made for this os. Only way to do it is to add it via apps&features. So i kinda was on the right path i just didn’t do it the right way. It works perfectly now. Thanks for all your help.

Sure, no problem. Glad you have resolved this issue.

Yikes. Why on earth would WD’s diagnostic/firmware app rely on Windows Media Pack (an optional windows component)?

I guess a lot of US-centric companies might make this mistake. Adobe Lightroom also is half broken for Windows 10 N users. At least the WD app errors out so you know it is broken (lightroom doesn’t). Would be nice if the WD development team didn’t build a bloated app dependent on media features. We want diagnostics for warranty and sometimes firmware updates. We don’t need another app that thinks it deserves to run all the time in the background. This is why I hate windows.