SSD capacity and connection unknown

On two Dell desktop computers I have replaced the HDD with SSD WD Digital Black SN700.
After installation The WD SSD dashboard software can’t detect the SSD capacity (unknown) and the connection (unknown).

In time and prior to the installation of the SSD, both Dell computers - one Dell Optiplex 7040 and one Dell Precision 3420 - were upgraded from W7 professional to W10 professional.

Because of unknown reasons the Dell Optiplex 7040 gave more and more blue screens after the upgrade.
After some irritating months I decided tot install W10 from the bottom up on the Dell Optiplex 7040 (Full fresh install, no upgrade).
Surprisingly the WD Dashboard software detects now the SSD capacity (PCIe 3.0 x 4) and also the connection (PCIe 3.0 x 4).

The Dell Precision 3420 works fine after the upgrade but still don’t show the SSD capacity (unknown) and the connection (unknown).

Is there some way to make it detectable?
If possible I don’t want to make a clean and full install of W10 because it take a lot ours of working.

Problem solved !!!

Dell has the unfortunate habit of delivering their systems with the SATA Operation (BIOS) set to RAID and not to AHCI.
However, it is not possible to change the BIOS setting directly during start-up, as this results in a non-starting system.

I changed the SATA operation mode from RAID to AHCI in BIOS setup according the following procedure:

  1. Type cmd inside the search box
  2. Right-click on cmd and select run as administrator
  3. Type bcdedit /set {current} safeboot minimal and press ENTER
  4. Restart your computer and enter BIOS Setup by pressing F12
  5. Change the SATA Operation mode from RAID to AHCI
  6. Save the BIOS changes, exit Setup and Windows will automatically boot in Safe Mode.
  7. Type cmd inside the search box
  8. Right-click on cmd and select run as administrator
  9. Type bcdedit /deletevalue {current} safeboot and press ENTER
  10. Reboot once again and Windows will automatically start with AHCI drivers enabled.

The Dell Precision 3420 system is starting up normally and now shows the SSD capacity and the connection correctly.

By the Dell Optiplex you can enter the BIOS with “F2”.
I also had the problem on a " Dell Optiplex 7090 SFF ". The Dell are all set to “RAID” in the initial setting. This worked with ther build in 250GB NVMe - and from an other Dell , the 512GB NVMe.
But not with my new " WD red SN700 4TB " . . Find no Driver for this NVMe .
In the BIOS I saw the WD red SN 700 4TB , correct, with serial number… but during installation it wasn’t there when the CD looked for a hard drive.

When I set RAID to AHCI in the BIOS, it find the driver and Win 10 was able to be installed.

Short :
F2 to enter the BIOS . Dell BIOS must set from Raid to AHCI . It is better for all SSD and NVMe