Srt files and ps3 media server: Newbie


I am setting up my first WDTV Live today.


Setup has gone well with WDTV Live except in one area. Let me describe

* Streaming from Windows 8 machine via DLNA
* All file types play fine through PS3 Media Server on WDTV Live
* All files with hard coded subs play fine through PS3 Media Server on WDTV Live

My one area of problem is with srt files.

The PS3 Media Server I believe is correctly locating the srt file (same folder, same name.
On WdTV Live, the movie is shown as “Movie Name - {External Subtitles}” which shows that the srt file is being recognized.

This exact file plays correctly when streamed to my PS3.

But when displayed on WDTV Live, no subtitles show up.

Does this have anything to do with me using the PS3 Media Server to load the SRT file? I was unsure if WDTV Live could handle an srt file on its own with out the media server getting in the way…

Thank you for any guidance you might be able to give.

I performed one experiment.

I loaded the movie and srt file on to a usb stick and played it as local media on the WDTV Live and it played correctly showing the subs.

So that showed me that WDTV Live understands srt files at least locally.

So I went back to the PS3 Media Server and disabled its handling of subs and tried to stream again.

This time on WDTV Live the movie title was displayed as “Movie Name” and did not include {external_subtitles} in the name.

When playing the movie, no subs appear.

You need to embed srt files if you watch over DLNA. Over network shares that’ not necessary.

1 Like

Ok thank you. I have a program that can hard code the srt’s so I will do that instead.

I am not familiar with network sharing so I will have to read up on that.

Embed, not hardcode. Just mux them into your MKV and you will still be able to turn them off.

Muxing (Softcoding) is definately the way to go

Because on the WDTV while watching a movie,  you change the Subtitle Size, Position, Color, Borders etc.

(eg. i find this handy with widescreen movies with large black borders at the top and bottom.  I personally like to change the size and move the vertical position of the subtitles into black border area so they aren’t overlayed on the film area)

I am hardcoding them because I do not want to turn them off. These are the subtitles that are for the foreign parts only, as it would be shown in the theaters.

My files are not mkv, they are mp4.

maldini wrote:
My files are not mkv, they are mp4.

That doesent matter, MKVMerge can mux srt’s into mp4 and My MP4Box as well

you do realise…  hardcoding subtitles requires re-encoding the entire video which will result in video quality loss ?

Muxing or Softcoding subs … no re-encoding   no video quality loss

Anyways, it’s your decision … best of luck with whatever you decide to do



1 Like