Spinning Arrow of Death - Possible Solution

Spinning Arrow of Death -WDTV Live can’t play any files except after reboot. After a while, fails again.

I had this issue as has been described in various ways in various threads. I tried everything, even got my WDTV Live SMP replaced under waranty. (didn’t help).

Some users reported it happened only when screen saver was enabled. (not in my case)

Some users resolved it by changing thier network setup (router, switch, etc) but for most of us the issue has persisted.

I think Siskin has discovered the root cause in this thread…


In my case it worked. If you don’t have a QNAP NAS then very likely you have something in your network (router, bit-torrent client, etc) that is sending out uPnP packets on the network. It appears to be what is causing the WDTV to go into the fault condition.

I tried posting this in the various many threads that are variants of this issue, but they were all taken down due to “cross posting”, so I am putting the info here. A BIG thanks to Siskin for figuring it out. :smileyvery-happy:

1 Like

Hi, thanks for sharing that this solution worked for you. 

Well, I tried another reproach, I found out somwhere ( can for the life of me, not remember where ), that the WDTV, does not like DHCP-servers ( it can be fixed with some rather fancy programming on your server ), so I decided to reconfigure my server to have a static IP in stead, and it has worked like a charm, for about a week now.

My server is a BlackArmour NAS 110.

Let me know if it works for any of you guys?

I also have a BlackArmour BA110 and have been struggling with this problem myself for a number of months.

However my BA has had a static IP since day one.

After countless WDTV resets, firmware updates, media library rebuilds I tried Siskin’s suggestion here last night:


Kudos to Siskin for his effort on this.

This initially seemed to fix the problem, but this issue came back. So this got me thinking about the cause being UPnP.

I went into my router settings (Zyxel P-660HN-F1Z) and in the UPnP settings unchecked ‘Allow users to make configuration changes through UPnP’

The WDTV Live streaming has now been running for about 5 hours without the symptoms of:

* Unable to play any file (except VOB) when the unit has been left idle for about 30mins

* Spinning arrow of death when stopping a movie (includes Stop & Home button)

* Soundtrack still audible after quitting playback (includes Stop & Home button)

* Unable to quit a slideshow if unit left idle for 30mins or more

Hope this is of some help to those who may still be struggling with this.



jhl102 wrote:

I found out somwhere ( can for the life of me, not remember where ), that the WDTV, does not like DHCP-servers

Probably because that’s bull, I’m using DHCP.

Techflaws wrote:

jhl102 wrote:

I found out somwhere ( can for the life of me, not remember where ), that the WDTV, does not like DHCP-servers

Probably because that’s bull, I’m using DHCP.

DHCP for the WD TV units is fine.  DHCP for your file/media server can be a problem, since the server’s IP might change each time it is rebooted.  I understood that jhl102 was talking about giving his file server (NAS) a static IP address.

Exactly  ncarver :smiley:

_ By the way, I found this other solution below, on another forum. _

I’ve been battling this issue for a few weeks and I have found a solid workaround. Here is a description of the problem and my experiences with troubleshooting and resolving:

The Problem:

When a Seagate BlackArmor NAS is present on your network, the WD TV Live SMP and WD TV Live Hub will not play video files reliably.

Detailed Symptoms:

When you attempt to play an .MKV, .MP4, .AVI, .MPG or .FLV file, you will see the spinning orange arrow/circle but the video will never start. Sometimes you can get the device to play a video file once after a reboot but it will refuse to play any additional video files after that.

Important Notes:

  • This issue does NOT seem to affect playback of .ISO files. Even when the device refuses to play other video files, it will play .ISO files just fine.
  • The issue is independent of where the video files are stored. Even if you are trying to play the video files from the local hard drive in a WD TV Live Hub or from a USB attached drive on a WD TV Live SMP, the symptoms persist.
  • If you shut down the Seagate BlackArmor NAS or simply disconnect its ethernet cable while you boot up your WD TV Live device, the symptoms will appear to be resolved for up to 30 minutes. Even if you plug the NAS back in after the WD has booted up, things will seem to be fine for a while before the symptoms suddenly reappear.

That last point makes troubleshooting extremely frustrating because a reliable test of any attempted fix/workaround takes close to an hour to properly validate.

The Workaround:

In searching the web, I found several reports of similar symptoms (including this thread) without anyone reporting a confirmed fix or workaround. I believe I have finally worked out a solution that should work for most people. The only people that it will not work for are those who are using Dynamic DNS services with their NAS.

  1. This workaround requires you to enable SSH access to your Seagate BlackArmor NAS. Hajo Noerenberg has written a tutorial to accomplish this here: 


  1. Once you are able to SSH into your NAS, you need to edit the “/etc/init.d/rcS” script and comment out the line that calls the “/usr/bin/nic_ip_mon.sh” script.

  2. After you’ve made the change, reboot the NAS and then reboot your WD TV Live devices.

That’s it. That should fix the problem. It may also break your dynamic DNS setup… assuming it even worked properly to begin with. I have validated this with two devices (a WD TV Live SMP and a WD TV Live Hub) streaming file after file for two straight hours without any symptoms reappearing. I then rebooted the WD TV Live Hub again and continued streaming for another 30+ minutes without any issues.


So what was happening in the first place? I can only speculate because I’ve wasted a ridiculous amount of time just getting this far. A complete answer would require me enabling ssh on the WD TV Live and my motivation is running low now.

What I do know is that the /usr/bin/nic_ip_mon.sh script is supposed to check your BlackArmor’s internal IP and your network’s external IP address periodically in order to update the dynamic DNS information for your NAS. To do so, it uses a test utility from the MiniUPnP Project called “upnpc”. This tool is supposed to identify a UPnP Internet Gateway Device on your network and query it for redirection information including the external IP. It queries this information frequently and is supposed to update dynamic DNS when it changes but the script is horribly written and doesn’t accomplish what it is meant to do unless you have a network configured in a very specific way. Now, I don’t know if the symptoms on the WD would disappear if your network configuration happened to match what Seagate’s amateur shell scripters had in mind when they wrote this garbage, but that’s irrelevant.

Seagate can’t take all of the blame here either. I have no idea what is happening on the WD side of the fence but they screwed something up so badly that an unauthenticated network peer can cause a denial of service. If anybody else wants to take this information to Seagate and/or Western Digital to try and get them to fix their junk, please do. At any rate, things are working for me right now and hopefully this will help the rest of you in a similar situation.

1 Like


My SMP has now been running without issue since my post last Wednesday.

Since then I have at last been able to:

* add my Photos folder from my NAS to the Media library. This contains about 10,000 pictures. (Linux share)

* add Music contained on an Autonomic MMS. (Just under 480Gb - Windows share)

I have had these two disabled for the past couple of months as each time I attempted to play a photo slideshow or play any music the SMP would lock up.

Note that I switch off the SMP at the wall each night so the unit gets re-started at least once a day.

Kudos to jhl102 for your very incisive post into the SMP with BA NAS. Had the afore mentioned fix not worked then I would probably be trying your solution this coming weekend. Your analysis of the problem with the BA was very helpful.